[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Help with Zip Drive



 I just got a parallel port Zip 100 drive. I have the ppa module loaded,
along with scsi support, scsi disk support. I do not have any scsi drives,
only the zip on /dev/sda4. The zip is recognized during boot, and I can
read it, format it with the iomegaware tool (iw), mount it, all without
problem. I have problems when I  try to write to it. After the cp command
the system hangs for a while. When it comes back I have lost the use of
the keyboard but not the mouse, and I have to reboot.
Here is what seems to be the relevant part of /var/log/messages.

 Jan  2 10:09:21 main kernel:  [worker_thread+0/702] worker_thread+0x0/0x2be
Jan  2 10:09:21 main kernel:  [kthread+183/189] kthread+0xb7/0xbd
Jan  2 10:09:21 main kernel:  [kthread+0/189] kthread+0x0/0xbd
Jan  2 10:09:21 main kernel:  [kernel_thread_helper+5/11] kernel_thread_helper+0
x5/0xb
Jan  2 10:09:21 main kernel: Code: f3 6d 8d 5d 02 b9 2c 00 00 00 89 c8 89 da ee 
8d 55 01 ec 89 
Jan  2 10:10:01 main kernel:  <6>parport0: ppa already owner
Jan  2 10:10:21 main kernel: scsi: Device offlined - not ready after error recov
ery: host 0 channel 0 id 6 lun 0
Jan  2 10:10:21 main kernel: SCSI error : <0 0 6 0> return code = 0x70000
Jan  2 10:10:21 main kernel: end_request: I/O error, dev sda, sector 554
Jan  2 10:11:24 main kernel: lost page write due to I/O error on sda4

How do I prevent the scsi device from going offline?
Any help appreciated.
Thanks
Jerry



Reply to: