[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems copying files from digital camera (sid)

I had some problem copying files from my camera recently. Could it be a
kernel issue? Here the details in case someone can help me trace the problem: 

I've been happily using a digital camera (Minolta) for several months now.
Since it uses USB Mass Storage, I only need to define an entry in my fstab, 

/dev/sda1     /camera  		auto   defaults,user   	 0     0

and with mount /camera it is ready to access the memory card (SD) and copy
files to the hard disk. A few weeks ago I bought a new SD card, and when I
filled it with photos, I had problems with two of them to copy. 151 photos
without problem, only 2 of them.

I was working in my sid laptop, and I received an input/output error message
on the console. When I saw the copied photos with eog, gthumb, or anything,
only a part of the image was visible, and the rest was gray. One of the
application complains about a premature end of jpeg file. If I see them in
the camera itself, no problem.

It was the first time I used the card, so I was worried that
it was defective, but I tried in a computer at the store where I bought it
and all pictures were seen complete. I now tried at my office's woody
machine, and no problem. I could copy them without error. 

At the office I'm using kernel 2.4.18-bf2.4 (woody), and at home kernel 
2.4.19 (sid)

Any suggestions to trace the problem? Maybe I should try a newer kernel.
I've just hadn't had the time during this week I'm afraid. Other ideas?

Thanks in advance,


Reply to: