[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: no cdaudio with alsa but ok with oss

Greg Folkert wrote:
On Tue, 2004-11-02 at 10:02 -0600, Hugo Vanwoerkom wrote:

Hi Debian!

I spoke to soon, saying that the migration to alsa was a piece of cake.

I have all sound, but no cd audio. I did have that with oss.

The cd slider does not show up in aumix nor alsamixer.

I googled for a clue.

libcdaudio is installed of course.

Anybody give me a hint?

To install alsa:
1. I enabled alsa and the card in the kernel but without modules.
2. I installed alsa-base.

That gave me sound. I forgot to test the cd, until today.

1. Do you have the Redbook Audio Cable installed from said CDROM device
to said Sound card CD-IN input?
2. If not, did you remove it during the installation of alsa (wink
wink... joking here, unless you did remove it)
3. Have you tried Digital Audio Extraction, this is what "ripping" a CD
does. I know XMMS and Rhythmbox (only music stuff I use) does both.
4. Make sure you have "unmuted" the CD-Audio.

The problem is the CD-Audio slider is not present, like I said in my post. Not in alsamixer nor in aumix. In aumix it was present when I ran OSS. So the cable, etc. is like it was with OSS a week ago.

I found a post in Spanish: http://groups.google.com/groups?hl=en&lr=&threadm=3d8798f4_3%40news.arrakis.es&rnum=18&prev=/groups%3Fas_q%3Dalsa%2520cdaudio%26safe%3Dimages%26as_scoring%3Dd%26lr%3D%26num%3D100%26hl%3Den that describes it and the guy went back to OSS. I won't. The answer is someplace. It isn't a bug because nobody talks about it.

Somehow Alsa has decided there is no cdaudio to be had.
I see no kernel config parms pointing to it.
Don't tell me I have to find their mailing list to find out :-(


Reply to: