[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: boot problems with grub

On Fri, Oct 01, 2004 at 01:50:57PM -0700, Jonathan
> I have been using debian with kernel 2.4.25 (I tried
2.6.8 but it had 
> with my onboard sound and so I stuck with 2.4.25).
> My problem is the following:
> I left emule running overnight (which was never a
problem before). I
> found that emule had failed and shut down my
computer. When I turned
> it on emule would not work. But more importantly, my
system was slow.
> Eventually KDE 3.0 decided to freeze on me. So I
manually shutdown
> and restarted. But since then I haven't been able to
boot. Grub
> returns error 18 at stage 1.5. I tried booting with
a Knoppix 3.0 cd
> to check my harddrive. However, Knoppix tells me
that ext3 fs cannot
> be viewed (the linux harddrive uses ext3). I have
been told that
> Knoppix should recognize ext3, so does that failure
tell me that my
> hd is screwed and needs formatting? Or is there a
way to reinstall my
> boot loader without rewriting my partition table?
(boot loader
> contains several linux kernels and windows, if that
makes a
> difference).
>>If the partition can't be viewed, your problem is
probably more 
>>than the boot loader.  Have you tried to fsck that
partition?  Have
>>you looked at the partition table with fdisk -l ?
>>According to "info grub", error 18 is "Selected
cylinder exceeds 
>>maximum supported by BIOS".  Do you have an old PC
with a newer hard 
>>drive, such that the BIOS can't see the entire
drive?  >>Do you (or did 
you) have a separate boot partition?

My computer is a late 90's Compaq Presario, but I've
been running debian on my PC for several months. So I
don't think that is an issue. I can only boot using a
knoppix cd so everything is readonly. I ran fdisk -l
and both /dev/hda and /dev/hdb cannot be opened.
However, hda isn't effected. I can mount it without a
problem. hdb is the disk with linux and the where the
problem lives. fsck won't work.

To the other reply, I can't boot into anything other
than knoppix. linux 2 and starting grub does not do
anything, but thanks for trying!

- Jonathan

Do you Yahoo!?
Declare Yourself - Register online to vote today!

Reply to: