[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with prebuilt kernel ALSA


Ryan Waye (<rmw998@gmail.com>) wrote:

> After a short testing run of SuSE, I have decided to come back to
> Debian (it is much faster and customizeable)
> But for some reason my sound will not work.
> I boot using linux26 to install, and everything goes smothely.  I go
> into gnome, and I attempt to adjust the volume, but there according to
> the gnome-mixer there is no sound card.  So I run lsmod and get the
> following:
> Module                  Size  Used by
> snd_via82xx            26660  0
> snd_emu10k1            80904  0
> via82cxxx_audio        26120  0
> emu10k1                71684  0

Hotplug or discover loaded the OSS drivers first. Update to the latest
hotplug version, which blacklists the oss drivers automatically, and
blacklist the OSS drivers for discover manually. Or remove discover, if
you don't need it.

> As you can see, the kernel has loaded modules for soundcore, sound and
> both my Creative SB Live LS and my onboard Via audio chip.  So I tried
> installing alsa, even though it was apparent it was built into the
> kernel, and get this:
> apt-get install alsa
> [no errors]

alsa is a virtual package provided by alsa-base. Also install alsa-utils
and alsa-oss, it they are not already installed.

> alsaconf
> [detects and configures card correctly]
> then after exiting alsaconf I get this
> Running update-modules...
> Loading driver...
> Restoring ALSA mixer settings ... failed:
>        You may want to run 'alsactl restore' manually to view any
>        errors.
> Setting default volumes...

The card cannot be found because the ALSA drivers cannot claim it. You
have to make sure that the OSS drivers are not loaded. Also
remove /etc/modprobe.conf. Make sure you have /etc/modprobe.d/sound
with alias entries for your cards.

best regards
 Andreas Janssen

Andreas Janssen <andreas.janssen@bigfoot.com>
PGP-Key-ID: 0xDC801674 ICQ #17079270
Registered Linux User #267976

Reply to: