[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dual Boot Problem

The strange one about this is that to restore the mbr in xp you are supposed to boot from the xp intallation cd, select recovery console and then run fix mbr and fix boot (might be fixmbr and fixboot, with no spaces) I wonder what fdisk /mbr did? Is partion 1 Fat32 or ntfs?


Patrick Moroney wrote:

Partition 1: 35g - Windows XP (ick - for my wife & kids)
Partition 2: 1g - /
Partition 3: 1g - Swap
Partition 4: 500m - /tmp
Partition 5: 5g - /var
Partition 6: 75g - /usr
Partition 7: 20g - /home

RRPotratz wrote:

Patrick Moroney wrote:

I'm trying to install Debian Sarge stable as a second operating system on a 200 gig drive and not having a lot of success. The installation goes fine; I install Lilo in the MBR, the system goes for a reboot and then I get the following errors upon reboot:

request_module[block-major-3]: Root fs not mounted
VFS: Cannot open root device "302" or 03:02
Please append a correct "root=" boot option
Kernel panic: VFS Unable to mount root fs on 03:02

Please note, the reboot is unsuccessful, I never get to the step where it asks to set up mail or create a root password. I just get the above message. I can't scroll up to see any of the other messages.

To recover and make the system so that I can at least boot back into windows is using a dos boot disk, do a "fdisk /mbr" - clear out the MBR, and then using debian's fdisk, blow away debian partions, and mark the windows NTFS as bootable. This has worked many times being as I've tried Lilo, Grub, and GAG as boot loaders - all successful.

The machine is x86 box with ASUS motherboard, AMD 1800 CPU, gig of RAM, ATI video card, and Audigy sound card. Windows occupies the first 35 gig of the 200 gig board.

Should I make the system so that it will only boot into debian with a floppy? Any suggestions would be greatly appreciated.

Also note, I'm running Woody at work no problem, but when I try to install Woody at home, the natsumi driver does not work for my Netgear ethernet card - and therefore cannot complete the installation.


What version of windoze? What does the rest of the partion table look like? How have you tried to setup the linux partitions?


Reply to: