[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: moving to the 2.6 kernel? (http://lists.debian.org/debian-user/2004/06/msg03105.html)

I saw your message on the net (see subject) and thought that you might have a solution for my problem.
I'm running Debian and don't wanna have OSS emulation because it shouldn't be neccesary (why use an extra layer to retain backward compatibility if you're new to Linux and don't have any 'backward experiences' ;-)
This message has been posted on several lists before, but with no response.
Subject: How to integrate ALSA
Hello Free World!

I am quite new to all of the Linux stuff but learning fast, so don't be scared
to respond in way's I 'might not understand', I'll figure it out ;-).
I have recently made my own Debian Kernel (now running nice 'n smooth...) and
decided to go with ALSA - I used the original 2.2.20_compact kernel which was on
the installation diskette (nope, I have no CD-burning equipement) and that
didn't include sound support, so I made this kernel. But now there are still no
system-sounds! If I use one of my other 2.4.19 kernels (I have made 23 in two
months before I was satisfied) with no ALSA but with the old standard sound
support (deprecated since 2.6.6 but not yet available in 'debianized' version)
it does work! I can play my music though through ALSA with the nice Alsaplayer
(using the alsa-module).
I figured that Gnome wants ESound as it's sound system so I installed
libesd-alsa0 to be able to hear 'them silly system-sounds'... but they don't do
what they should! (yet)
When I fire up the sound-monitor applet it says esd is inactive so I take my
terminal and go "ESD", resulting in loads of variants of:

  Couldn't open any alsa card! Last card tried was 0
  Error openin card 0: Sound protocol is not compatible
  Audio device open for 44.1KHz, stereo, 16bit failed
  Trying 44.1KHz, 8bit stereo.

and finally:

  Couldn't open any alsa card! Last card tried was 0
  Error openin card 0: Sound protocol is not compatible
  Sound device inadequate for Esound. Fatal.

So I guess there is some heavy mis-comunication going on between alsa and esd...
The easiest solution I can think of is just to forget ESD and set things up for
use purely with alsa. It must be possible since the reason I chose Gnome instead
of KDE was that Gnome is Free, and KDE is not. I only don't know how it should
be done...

please respond by mail to j.witteveen@mail.ru in English or Dutch (the reason
for me to have a .ru e-mail adres is just: it is free, as in: free screwdrivers)

Kind regards,
Jouke Witteveen

Reply to: