[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: File size limit exceeded for files > 2GB

Emiliano wrote:

Hy everibody,
when creating files bigger than 2GB I get error "File size limit
I use woody, kernel 2.6.7, libc6 2.3.2.ds1-13, and this is the output
from ulimit -a:

core file size        (blocks, -c) 0
data seg size         (kbytes, -d) unlimited
file size             (blocks, -f) unlimited
max locked memory     (kbytes, -l) 32768
max memory size       (kbytes, -m) unlimited
open files                    (-n) 1024
pipe size          (512 bytes, -p) 8
stack size            (kbytes, -s) 8192
cpu time             (seconds, -t) unlimited
max user processes            (-u) 10239
virtual memory        (kbytes, -v) unlimited

I can't get the solution to this problem.
Have I to recompile the utilities ( scp, ftp and so on ) against new
kernel headers? ( hope this is not necessary).



Ok, solution found.
I recompiled the ftp and scp utilities, ans this (tried ftp on 6GB file, scp on 2.2 GB) just worked ok...now i've my 6GB backup on my Debian.

Thanks Stefan, I thought i had to recompile, your hint definitively pointed it out.

Thanks John too: I only moved a monolitic 2.6 kernel on this woody, which is our production environment, everything else is original woody :).



Reply to: