[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: systemwide umask definition?

I have a similar experience with umask

in /etc/profile I have a line 
umask 0002  # to give owner and group rw access.

in /etc/login.defs I have the same (why capitals?)
#       UMASK           Default "umask" value.
UMASK           0002

and nothing in .bash_profile, but it still comes up 0022 when I check it with 

anyone help?


On Friday 16 July 2004 17:49, Trollcollect wrote:
> Thanks to Jacob, i figured out that my statement/request was somewhat
> unprecise. What i really do want to do is to set a umask for OpenOffice
> w/kde, as well as all other kde applications. I noticed that if i open a
> terminal session, check the umask, it will not be set according to what i
> put in /etc/profile or /etc/login.defs. If, however, i su - into the same
> user, i see th correct umask. That leads me to the guess that kde sets a
> umask differently and independant of the login / standard umask. So the
> precise question would be: Where can i define a system wide umask for kde
> sessions?
> TIA,
> Dan
> "Jacob S." <> wrote:
> On Fri, 16 Jul 2004 16:53:46 +0200 (CEST)
> Trollcollect wrote:
> > Hello List,
> >
> > please reply Cc: to me as i cant follow this list from
> > work.
> >
> > My problem is that i cant find where to set the system
> > wide umask for my sarge system. I've tried to do it in
> > /etc/profile as well as /etc/login.defs, to no avail.
> > So desperate that i even tried a reboot :(
> >
> > Any pointers?
> What syntax did you use? On my Sarge system it's in /etc/profile with a
> simple "umask 022" line. Logging out and back in should be enough for
> this setting to take affect.
> What did you do to believe that the umask setting wasn't working?
> Jacob

Reply to: