[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: help with usb network



On Mon, Jul 12, 2004 at 09:51:57AM +1000, glenn wrote:
> On Mon, 2004-07-12 at 06:04, Joachim Fahnenmueller wrote:
> > On Sun, Jul 11, 2004 at 10:16:00PM +1000, glenn wrote:
> > > I'd like to attach my zaurus to my debian box from its usb cradle. The
> > > problem I'm having is that when I plug the Z in, or modprobe usbnet, the
> > > machine grinds to virtual halt for aprox 2 minutes while it registers,
> > > unregisters and reregisters the device - at least thats how I
> > > interperret it - this is a snippet from syslog: 
> > > (...) 
> > Which kernel version?
> > And isn't the correct module for the zaurus called usbdnet ?
> >                                                       ^
> I'm using 2.6.7-1-686 on the debian box - all the config described above
> is for the debian box, and usbnet is afaict the appropriate module for
> talking the zaurus. The zaurus is running openzaurus.

Yeah, sorry, there semms to be some confusion about it. I got it working a long
time ago with 2.4.18 kernel and usbdnet, but now usbnet is supposed to be
better. See http://www.linux-usb.org/usbnet/ .
> 
> On the zaurus side of things, Im not sure which  module it is - but it
> _seems_ ok. 

AFAIK there is no configuration necessary on the zaurus side.

> If I exclude hotplug from the debian side of things, then I
> can make a usb ethernet connection fine, but debian seems to drop the
> connection after any thing from 5sec to 5min. I only assume debian does
> the droping as usb0 ceases to exist on the debian box, but stays up on
> the zaurus.

You don't perhaps have a cronjob running that unloads the module?

Regards
-- 
Joachim Fahnenmüller

# Hi! I'm a .signature virus. Copy me into
# your ~/.signature to help me spread!



Reply to: