[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

USB mouse with kernel 2.4.26



having upgraded to the 2.4.26 kernel, i can no longer use my USB
mouse.  i _can_ use my USB camera cable, though, so i know it's not
wholly a USB deal.  i haven't changed my /etc/gpm.conf or my
/etc/X11/XF86Config-4 (the relevant bits of which follow):

/etc/gpm.conf:

device=/dev/input/mice
responsiveness=6
repeat_type=raw
type=imps2
append=""


relevant bit of my /etc/X11/XF86Config-4

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/gpmdata"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection


and, last but not least, the relevant (grepping `lsmod` for "usb" and
"mouse") modules in my kernel are:

input                   3648   0 [joydev keybdev mousedev evdev usbmouse hid]
mousedev                4308   0 (unused)
usbcore                63756   1 [scanner usbmouse usb-uhci hid]
usbmouse                2264   0 (unused)
usb-uhci               23568   0 (unused)

i feel like i'm missing a module in here.  i've also got evdev in
there, for what that's worth ....

this all worked with my 2.4.20 kernel, and i feel like there's an
upper bound to the number of modules i can just stick into my kernel
before i have to find something that works.  can anyone tell me what
i'm missing, here?

thanks!

</nori>

-- 
    .~.      nori @ sccs.swarthmore.edu
    /V\  http://www.sccs.swarthmore.edu/~nori
   // \\          @ maenad.net
  /(   )\       www.maenad.net/jnl
   ^`~'^
  
++     Sponsor me as I run my SECOND marathon for AIDS:       ++
++ http://www.aidsmarathon.com/participant.asp?runner=DC-2844 ++

Attachment: pgppw2mnmI5Hv.pgp
Description: PGP signature


Reply to: