[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian running kiosk-mode problems -solved

Shaun ONeil wrote:

On Fri, 18 Jun 2004 14:01:45 +0200, Paal Marker <paal@barum.folkebibl.no> wrote:
Shaun ONeil wrote:

On Fri, 18 Jun 2004 12:42:36 +0200, Paal Marker <paal@barum.folkebibl.no> wrote:

The problem is that X starts, but will not display galeon.

Shortly told the system is put up like this:
added user kiosk,  system configuration by /etc/inittab,
/home/kiosk/kiosk.sh    /home/kiosk/kiosk-session
/home/kiosk/.xsession  and in additional I have tried to solve the
problem by adding /home/kiosk/.xserverrc for being sure that the correct
X server is used.

/etc/inittab provides automatically logging by the line
/home/kiosk.sh   calling  "exec xinit /home/kiosk/kiosk-session --$xargs
/home/kiosk/kiosk-session  making no prompt for password:  "exec su -
--command /home/kiosk/.xsession   kiosk"
I'm no expert, but the first thing I notice here is that X is launched
by init, so has root's permissions.  If you un-comment the xsetbg
line, does that work?  I'm curious if 'kiosk' can use root's X

Thank you for your answer, and I think you found the problem.  Trying to
xinit as user gives message that user is not authorized to run the X
server. Surprisingly, as this was never a problem in redhat.  Is there a
way to give user kiosk the authorization for using X server?

Uncomment the line

#/usr/bin/X11/xsetbg /home/kiosk/wallpaper.gif

had then of course no effect.

And for your question, /usr/bin/galeon -df,   -df makes sure that galeon
starts in full screen. (in redhat it worked)

you might like to try changing "allowed_users" to "anybody" in

iirc the default is to allow users that are logged in on a local tty
.. I found changing mine to read 'anybody' would allow me to start X
from within screen (where you're assigned a /dev/pts/*, not a
/dev/tty*) .. a similar situation where the user is local but doesn't
appear logged in.

I'm not sureif that's a good solution long-term .. it'd depend who has
how much access to the machines.

(I know this should be done with dpkg-reconfigure, I just can't
remember which package you'd want to be reconfigure'n .. appologies
for demonstrating 'all the wrong ways')


I found the solution for the problem by I-do-not-know-how-many-different-edits of the .xsession file. The solution was the line: /usr/bin/galeon --display=:0 -ndf. To define display was never necessary in redhat. Useful tip for those who may make a similar system, the df arguments makes galeon start in full-screen and disables the crash-dialog

Reply to: