[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation problem: can't mount CD drive

Catatonic Porpoise wrote:

I'm trying to install Debian GNU/Linux 3.0rev2 i386 by CD, using a copy of
binary CD 1 I burned myself, on a new machine. The CD boots and the
installer runs fine, it gets to the part where it installs the kernel and
driver modules, and then it asks me what to install from - CD, floppies,
NFS, etc - even though the install guide indicates that it should know to
install from CD-ROM. When I select the CD-ROM option, it says the CD was
not mounted successfully (that's all, no reason given or anything).

I tried mounting it manually from ash, the little shell built into the
installer, with (from the / directory) "mkdir cdrom" "mount -t iso9660
/dev/cdrom /cdrom". It gives me a line saying that /dev/cdrom is read-only
and it's mounting it that way, then it says "Mount failed: invalid
argument". /cdrom is a symlink to /hdc, which I understand is supposed to
be the master of the second IDE device; according to the BIOS, this is
correct. I have tried:

-checking the options I used in Nero against the ones given in the install
guide, and burning another CD
-setting "Plug 'n Play OS" to No in the BIOS setup
-removing write privileges for everyone from /cdrom

None has helped. Any ideas? (I'm new to Linux, but I've had a bit of
experience with FreeBSD. [I ended up not using it much after it was
installed, because it didn't have a driver for my network card.] In case
it matters, this computer hasn't and doesn't have any other operating
systems installed.)


I've never had much experience with doing a CD-based install. Somewhere near the point where you're at, I've always done a net install. (Of course you may have no networking, so this might not be an option for you.)


Reply to: