[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: No windowmanager when using vnc?

On 2004-05-08 18:45:46 +0100, Rich Stanton wrote:
> I then tried creating a .vncrc file containing the line '$vncStartup =
> "$ENV{HOME}/.vnc/xstartup";'.  This time, when I started vncserver
> instead of saying 'Starting applications specified in /etc/X11/Xsession'
> it said 'Starting applications specified in .vnc/xstartup' however when
> I connected to the vnc session, there was still no windowmanager.  When
> I checked the logs this time there was a line to the effect of
> '/bin/windowmaker - cannot open display debian:1'.

Try another window manager to see if this works (e.g. fvwm2), or an
xterm. If this works, there probably is a bug in windowmaker.

Otherwise, the problem could be your display (debian:1), in particular
if "debian" can't be resolved (I had such a problem in the past, but
not specifically to vnc). Here, $DISPLAY is ":1.0", and there's no

Vincent Lefèvre <vincent@vinc17.org> - Web: <http://www.vinc17.org/>
100% validated (X)HTML - Acorn / RISC OS / ARM, free software, YP17,
Championnat International des Jeux Mathématiques et Logiques, etc.
Work: CR INRIA - computer arithmetic / SPACES project at LORIA

Reply to: