[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Sid] perl breaks apache


On Wed, May 05, 2004 at 12:37:37AM -0700, Paul Scott wrote:
> Ok.  I was stupid enough using aptitude to let this slip by until it was
> already removing Apache.  I have added testing to my sources-list to get
> access to those versions of Perl packages but I can't quite figure out
> how to get either aptitude or synaptic to let me remove the 5.8.4-1
> versions and install the 5.8.3-3 versions.
> I know I can do this with apt-get but I am lead to understand that
> aptitude will not track what I have done and might get stupider if I do
> this.  Is there an aptitude or synaptic answer or should I just use
> apt-get or dpkg?

You can fiddle around inside of aptitude (select appropriate version,
mark for installation, resolve brokeness...), or you could invoke
aptitude just like you'd do with apt-get, ie.
# aptitude install perl=5.8.3-3

This will need some adjustment, though, as you'll have to list all
packages you intent to downgrade.


Attachment: signature.asc
Description: Digital signature

Reply to: