[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgrade to Sarge kills X

On Sun, 02 May 2004 21:08, Niels L. Ellegaard wrote:
> cr <cr@orcon.net.nz> writes:
> > The upgrade asked me a number of questions about my monitor and
> > video card, some of which I probably got wrong, but it made no
> > visible difference as my /etc/X11/XF86Config-4 is completely
> > unchanged.
> During the upgrade you are asked a set of questions about the
> system. Ideally the answers to these questions should result in a new
> XF86Config-4. So ideally you should never be forced to edit your
> XF86Config-4 yourselves. If you wish to change the settings of
> your x-server, you can write the following
> dpkg-reconfigure xserver-xfree86
> If you edit your XF86Config-4 yourselves after the update, then you
> have to do a bit of work to force dpkg-reconfigure to take control of
> XF86Config-4 again. The following header explains it nicely.
> # This file is automatically updated on xserver-xfree86 package upgrades
> *only* # if it has not been modified since the last upgrade of the
> xserver-xfree86 # package.

Yes, that explains *exactly* why dist-upgrade didn't alter my XF86Config-4   

The only thing it didn't do was put up an error message saying "You've been 
all over this with your great flat feet so I ain't touching it"  :)

> #
> # If you have edited this file but would like it to be automatically
> updated # again, run the following commands as root:
> #
> #   cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
> #   md5sum /etc/X11/XF86Config-4 > /var/lib/xfree86/XF86Config-4.md5sum
> #   dpkg-reconfigure xserver-xfree86

Just tried that.  
"xserver-xfree86 is broken or not fully installed"

So now we know   <g>

> Now you can use dpkg-reconfigure to create an XF86Config-4 that is
> taylored for the version of xfree86 that comes with Sarge. Perhaps
> this will help. (Remember not to delete the old version XF86Config-4
> :)

No danger of that, since all of Woody is still working in /dev/hda1.   It's 
only the copy in /dev/hda2 that I risked upgrading.    Paranoia is good  :)

> :
> > I tried looking at /var/log/XFree86.0.log, but couldn't see anything
> > with an EE (error) against it, and only one WW (warning) - Cannot
> > open APM - which I've got in Woody anyway.
> Well actually I had a somewhat similar problem myself (Bug
> Bug#204603). When I use Xserver-4.2 I get a signal 11 with no further
> intelligible error messages. If your log looks somewhat like mine,
> then you are doomed :) If they look different, then you should perhaps
> post the entire log
> http://lists.debian.org/debian-x/2003/debian-x-200308/msg00177.html
> http://groups.google.dk/groups?th=9ac4ac009ab6e231

I'll go check that out and see if I can spot anything significant.

> > Regards cr (back in Woody)
> Personally I got a nice system by using xserver-xfree86 from woody,
> and everything else from Sarge. This is not perfect, but at least it
> seems to work. It was easy to achieve this by editing my
> /etc/apt/preferences. (See APT-HOWTO). I have something like this:
> Package: xserver-xfree86
> Pin: release a=stable
> Pin-Priority: 800
> Package: *
> Pin: release a=testing
> Pin-Priority: 600

I just tried that again - wiped the partition, copied the whole Woody over, 
pinned xserver as above,  did a complete dist-upgrade - same result.   

Ah well, I'll fiddle around some more and see if any blinding light dawns.  


... "The answer, when found, will be obvious"

Reply to: