[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upgrade to Sarge kills X

I just tried upgrading from Woody to Sarge, the paranoid way, by 
copying my entire Woody system to a new partition and using
apt-get  -f  dist-upgrade    off the cd-roms.

The upgrade asked me a number of questions about my monitor and video card, 
some of which I probably got wrong, but it made no visible difference as my 
/etc/X11/XF86Config-4  is completely unchanged.   

However, on trying  startx,    I got the grey screen with the 'X' for a 
moment then it dropped back to the login screen.   (I'm using a text login).  
The only error message was "Could not init font path element 
/usr/X11R6/lib/X11/fonts/Speedo/, removing from list!"   
(But it didn't remove it, I kept getting the same error till I manually #'d 
it out in XF86Config-4.  It's probably irrelevant to the problem since my log 
in Woody shows the same message, and X works in Woody).

I tried looking at /var/log/XFree86.0.log, but couldn't see anything with an 
EE  (error) against it, and only one WW (warning) - Cannot open APM - which 
I've got in Woody anyway.

Does anyone have any suggestions where to look?   Or what has changed in 


(back in Woody)

Reply to: