[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt: Dynamic MMap ran out of room

on Sat, May 01, 2004 at 07:31:07PM +0200, micha (michael.wordehoff@gmx.de) wrote:
> First, i'm not on the list, so please cc to me.
> I saw exactly the same problem on a friends laptop, when he trtied to 
> upgrade to testing.
> Maybe it's caused by a misconfigured apt or sth. completely different, but 
> i should mention that
> I run a local apt-proxy version 1.3.6 from Debian stable - without any 
> problems, since half a year.
> Now i tried to upgrading to testing. After 'updating' to the new sources 
> list from aptitude ('u') the package lists
> seem to have been downloaded into the apt-proxy cache properly. For example:
> <<
> /home mi: ls -l /var/cache/apt-proxy/debian/dists/testing/main/binary-i386/
> -rw-r--r--    1 aptproxy nogroup      2,8M 2004-04-30 21:00 Packages.gz
> -rw-r--r--    1 aptproxy nogroup        81 2004-04-30 21:18 Release
> >>
> But when i start aptitude and it loads the apt cache, there's this error 
> message:
> <<
> Apt errors
> E: Dynamic MMap ran out of room
> E: Error occured while processing tqsllib0 (NewVersion1)
> E: Problem with MergeList
> /var/lib/apt/lists/localhost:9999_debian_dists_testing_main_binary-i386_Packages
> E: The package lists or status file could not be parsed or opened.
> >>
> There's no package list available, afterwards.
> When i request a new (offline) upgrade, it says
> <<
> Ouch!  Got SIGSEGV, dying..
> Segmentation fault
> >>
> The same occurs with unstable.
> Updating the package list still works for stable (woody).
> The package lists for testing and unstable (main) are quite large (> 2,5 MB)
> compared to stable.
> However i don't understand what's going on.
> This box has 256 MB (mostly unused) RAM and a lot of swap. It runs a kernel 
> 2.4.5 which never
> showed any memory problem.
> Any idea will be greatly appreciated !

    # echo 'APT::Cache-Limit "25165824";' >> /etc/apt/atp.conf


Karsten M. Self <kmself@ix.netcom.com>        http://kmself.home.netcom.com/
 What Part of "Gestalt" don't you understand?
    Ceterum censeo, Caldera delenda est.
		        SCO vs IBM Linux lawsuit info:  http://sco.iwethey.org

Attachment: signature.asc
Description: Digital signature

Reply to: