[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ALSA stopped working at boot (sid)

I had the same error yesterday after switching to the 2.4.25 K7 kernel image 
and installed the associated alsa-modules package.  I fiddled and fiddled, 
and eventually got the right modules to load and alsa working, but I couldn't 
tell you at which point things started working.  Actually, I couldn't get it 
working at all yesterday, and today when I re-booted it magically started 
working again, so whatever I had done to fix it was purely an accident and I 
have no idea what exactly the last thing I did yesterday to fix it.

Also, an upgrade to the system I did a few weeks back completely fudged my 
sound in general.  Even after getting alsa to finally work again, all sounds 
are skippy and distorted.  Prior to the upgrade I did a few weeks ago, 
everything sounded fine.  I've played with the mixer levels, but nothing 
seems to work.

Curiously, when I run /etc/init.d/alsa restart, I still get that same error 
you're getting.  I don't know what it means nor how to fix it though.

Sound seems to be still quite an issue with Linux.


On Friday 30 April 2004 07:47, Jonathan Heaney wrote:
> Hi,
> In the last week or thereabouts, my ALSA setup has stopped working,
> specifically modules etc failing to load at boot-time.
> At boot I get the output-
> "Restoring ALSA mixer setting ... failed:
> You may want to run 'alsactl restore' manually to view any errors"
> When I try that I (obviously) get
> "alsactl: load_state:1134: No soundcards found..."
> BUT - when I try /etc/init.d/alsasound start, (which afaik is what
> should be run at boot), ALSA starts fine, all the modules get loaded etc
> etc.
> I've not seen anything on the mailing list archives on this, but when I
> checked out bugs.debian.org for 'alsa-base', I see that a new release
> was made (1.0.4-2) around about the 26th/27th of this month.  I suspect
> this is probably the cause of the problem.
> Anyone else seen this/know of a fix to get the startup scripts to work OK?

Reply to: