[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: new install, sound not working (+2 bonus problems)

On Thursday 22 April 2004 09:26 pm, Phil Ramey wrote:
> Howdy,
> So last tuesday I got fed up with windows and
> formatted C: .... it was very satusfying....
> Anyway, I went through a couple of installs that were
> broken (PIBKAC, i assure you), until I landed on this
> install... let's see if I can re-construct, step by
> step:
> 1) installed using woody isos, bf24 kernel.  apt-got
> up to current sid
> 2) in first attempt to get sound working, i compiled a
> new kernel, 2.6.5, with ALSA, but the wrong drivers
> 3) incremented the "extra version" makefile option and
> re-compiled with the right drives and ALSA, no dice,
> still didn't work.  it detected the chip fine in boot,
> but didn't work.  gnome's volume control gave me crap
> for not being able to open /dev/mixer so i addusered
> my user into the audio group, which made it quiet
> down.  Inexplicably, no sound application worked
> except for Stones, the gnome stones clone.  sound
> started a few seconds into the game, and was
> low-quality thoughout.  Tried alsaconf, it didn't
> detect the chip.  alsaconf also gave error: "cannot
> find module SND" three times at run...  tried editing
> /etc/modutils/alsa to match what was shown for the
> ensoniq 1731 chip at www.alsa-project.org, but to no
> avail.  contemplated following the debian instructions
> at http://www.sonic.net/~rknop/linux/debian_alsa.html
> but got confused, and didn't, partially because it was
> referencing the 2.4.24 kernel, and i was running 2.6.5
> 4) recompiled again with proper driver and OSS, boot
> detects the chip (integraded on the mobo,
> don't'cha'know), and stones works better (music this
> time), but nothing else is fixed.  when i load any
> multimedia program, it complains about not being able
> to open /dev/dsp
> my suspects:
> -cruft from the first install that i didn't/don't know
> to clean
> -improper config
> -the usual plbkac
> I really don't know what you would need to help me,
> being a week old in linux, so please be gentle (/me
> cowers)
> Two other side problems...
> I have two hard drives and two cdrom drives, and only
> one of each is currently recognised by the system.  my
> unrecognised HD has ~20gigs of mp3s and such that i'd
> like to keep if i can... it's fat32 (converted with
> partitionmagic from NTFS for compatability)... i have
> Vfat compiled in, but... i don't know what to do to
> get them in fstab, etc...
> sort of related second side problem:  I have an iRiver
> iHP-120, 20gig hard-disk mp3/ogg/wma/etc player, that
> uses USB2.0 (or 1.1) mass storage... i installed all
> the kernel packages i could see though menuconfig that
> USB Mass Storage needed... but i don't really know
> where to go from there... there's USB1.1 on my mobo
> that works (my mouse!), and a USB2 PCI card that i've
> not confirmed works, yet.
> any help on any of my problems would be graciously
> thanked... thanks for even reading...
> --Phil Ramey

Hi Phil, I am fairly new to Debian as well, but maybe I can help your sound 
Try finding out which 'group' dsp is in, and then put yourself in that group.
ie, on my box the 'dsp' is in the group 'audio'.
Worked for me...

Reply to: