[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Anyone used Backports.org to upgrade a woody to 2.6?

On Wed, Apr 14, 2004 at 02:36:13PM -0700, Bill Moseley wrote:
> I see that there's both module-init-tools and a kernel-image-2.6.5
> (kernel-image-2.6.5-1-k7_2.6.5-0.backports.org.1_i386.deb)
> available.

There's another modules deb in the folder - make sure you have it
if you need to drop back to 2.4

> Anyone have success using those packages to update a Woody box?  One is 
> an Athlon XP 1800+, which I assume is should use the
> k7 kernel.  I also have a P4 and a PIII.

Yes. I roll my own kernel from vanilla. Athlon 1200.

> Any notes?  Did you add backports to source.list or download the .deb
> and use dpkg -i for the modules and kernel?

dpkg -i

> I normally build the kernels, but would really like to start using
> kernel-image packages to make upgrading easier.

Try make-kpkg.

Some problems I encountered:
I use devfs and devpts wasn't mounted(fun with ssh).
Modules names changed. Lots of them.
Programs in procps no longer work.

I'm considering dropping back to 2.4 until I can go to Sarge.


Reply to: