[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dial up problems when upgrading 2.4 to 2.6 kernel

Man! It worked! Besides lo, I had sl0 running and I guess that was the problem. So after shutting it down, I dialed out again and now it's working! Thanks a lot Marvin, and I hope it will help others with the same problem! But now I wonder why things like this happen with this new kernel?

----- Original Message -----
From: Marvin Stodolsky <marvstod@rcn.com>
Date: Sun, 04 Apr 2004 16:04:32 -0400
To: Subject: Re: Dial up problems when upgrading 2.4 to 2.6 kernel

And after shutting down the eth0  or whatever.
Do a new dialout,  if you have a result like
$ cat /etc/resolv.conf
you should then have functioning DNS navigaton


Marvin Stodolsky wrote:

> US Robotics 56k model 3CP5610A must be a controller chip modem, using > the standard serial.o driver under 2.4.n kernels
> and under 2.6.n modules in:
> # ls /lib/modules/2.6.3-test1/kernel/drivers/serial/
> 8250.ko  8250_pci.ko  serial_core.ko  serial_cs.ko
> ------------
> serial_core and either 8250.ko or 8250_pci
> See what is loaded with # lsmod
> The failure of ping tests means that naviagation is NOT working.
> This can be due to eth0 or some other COMM mode being active.  Check with
> $ /sbin/ifconfig
> lo Link encap:Local Loopback inet addr: > Mask:
>          UP LOOPBACK RUNNING  MTU:16436  Metric:1
>          RX packets:210 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:210 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 txqueuelen:0 RX bytes:11216 (10.9 KiB) > TX bytes:11216 (10.9 KiB)
> ppp0 Link encap:Point-to-Point Protocol inet > addr: P-t-P: Mask:
>          RX packets:571 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:620 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 txqueuelen:3 RX bytes:327714 (320.0 > KiB) TX bytes:106428 (103.9 KiB)
> The lo block is beneficial loopback testing.
> If you have any other block, say   eth0 , do
> # ifdown eth0
> and/or # ifconfig eth0 down
> The 1st Attachment explains.
> Also please download > http://linmodems.technion.ac.il/packages/scanModem.gz
>   under Linux
>  gunzip scanModem.gz
>  chmod +x scanmodem
>  ./scanModem
> will run diagnostics and output advice.
> Send me the output ModemData.txt but NOT the others
> MarvS
> scanModem maintainer
> Thomas Beresford wrote:
>> I don't know which driver my modem uses but it's an US Robotics 56k >> model 3CP5610A and it used to work perfectly with the old kernel. >> I´m pretty sure that I'm connecting to my ISP. I'm using wvdial to >> connect and I can see all the messages (sending login, password, >> authentication, starting pppd, etc). It doesn´t seem to be a DNS >> problem since I´ve installed the testing ppp package and the ping >> still doesn´t work, nor the numerical address nor the named address. >> What could it be?
>> PS: I noticed that the new kernel is loading the ipv6 module, could >> it be the problem?
>> ----- Original Message -----
>> From: Marvin Stodolsky <marvstod@rcn.com>
>> Date: Sat, 03 Apr 2004 18:42:48 -0500
>> To: Thomas Beresford <number18@linuxmail.org>
>> Subject: Re: Dial up problems when upgrading 2.4 to 2.6 kernel
>> >>
>>> Which driver does your modem use?
>>> Are you sure you actually CONNECT to the ISP
>>> Compare:
>>> #  ping
>>> 64 bytes from icmp_seq=0 ttl=48 time=239.2 ms
>>> 64 bytes from icmp_seq=1 ttl=48 time=240.0 ms
>>> 64 bytes from icmp_seq=2 ttl=48 time=230.0 ms
>>> 64 bytes from icmp_seq=3 ttl=48 time=230.0 ms
>>> with the named address
>>> # ping  novell.com
>>> If the numerical address works but not the named address,
>>> Then it is only a DNS problem.
>>> You may need some PPP support files from the testing distribution >>> for DNS to work
>>> Try rebooting under your old kernel.
>>> Within /etc/apt/sources.list, make a duplicate of all lines.
>>> Within the 2nd set, replace "stable" with "testing", for example
>>>     deb http://ftp.lug.udel.edu/debian/ stable main  non-free contrib
>>> goes to                                                  ====
>>>    deb http://ftp.lug.udel.edu/debian/ testing main  non-free contrib
>>> Then
>>>    apt-get update
>>>    apt-get -s install ppp
>>> (where -s is stimulate)
>>> If nothing dangerous is shown
>>>   apt-get install ppp
>>> MarvS
>>> Thomas Beresford wrote:
>>> >>>
>>>> Hello fellas,
>>>> I upgraded my debian system kernel from 2.4 stable to 2.6 testing. >>>> But now my dialup connection doesn't work anymore! I get to connect >>>> to my ISP, but i can't navigate. Could someone help me, please?
>>>> >>>
>> >>
>After Bruno Magnani, magnani.bruno AT alitalia.it >tersely reported on resolving problems of coincident use of ethernet and ppp connections,
>I asked him to please expand the report for inclusion in the Lucent DOCs/
>He returned a very nice report, which with very little editing is that below.
>The issue is much more generic than usage with the Lucent modem,
>so it is appropriate to also provide it broadly to Discuss@Linmodems.org
>Thanks again Bruno.
>These notes report about running a Lucent Microelectronics LT winmodem
>driver on a Compaq Armada E500 that is mostly used to connect to a
>Company's LAN through a network card.
>	- set up a handy configuration for dialup ISP accounts
>	- avoid touching existing network configuration files
>Technical context :
>	- distribution Red Hat 7.2 (Enigma)
>	- Kernel 2.4.7-10
>	- wvdial 1.41
>	- KDE kppp 2.0.8 (KDE 2.2-11, Qt 2.3.1)
>Evidence of applicability to a different context: NONE
>Please check the output of the following commands to verify your settings:
>	# uname -a
>	# wvdial --version
>	# kppp --version
>Startup Assumption
>I installed the source package ltmodem-6.00b9, and assume the process >of compiling, installing and autoloading the new drivers on your machine went ok. > >After that I now have: the new drivers installed at: > /lib/modules/2.4.7-10/kernel/drivers/char/lt_modem.o > /lib/modules/2.4.7-10/kernel/drivers/char/lt_serial.o ;
>the device node /dev/ttyLT0 (as the port to be referred in dialup scripts);
>the symbolic link /dev/modem --> /dev/ttyLT0 ; >an updated /etc/modules.conf as well as >an updated module configuration database.
>Setting up name resolution with wvdial
>The configuration file for this dialer is /etc/wvdial.conf, you can read through the wvdial man pages
>and the documentation file ../DOCs/wvdial.txt for setting it up (remember to create the symbolic link >"ln -sf /dev/ttyLT0 /dev/ttyS14" as suggested).
>Here is what I get when attempting a connection:
>	/home/bruno> wvdial libero
>	--> WvDial: Internet dialer version 1.41
>	--> Initializing modem.
>	--> Sending: ATZ
>	OK
>	--> Sending: ATM1L3
>	ATM1L3
>	OK
>	--> Modem initialized.
>	--> Sending: ATDT 00688531010
>	--> Waiting for carrier.
>	ATDT 00688531010
>	CONNECT 48000 V42bis
>	--> Carrier detected.  Waiting for prompt.
>	Username:
>	--> Looks like a login prompt.
>	--> Sending: xxxxxxx@libero.it
>	xxxxxxx@libero.it
>	Password:
>	--> Looks like a password prompt.
>	--> Sending: (password)
> ~Entering PPP mode.}-}*Async interface address is unnumbered (Loopback0)}-}*Your IP > address is MTU is 1500 bytes}-}*}-}*jO~
>	--> Looks like a welcome message.
>	--> Starting pppd at Fri Feb 22 17:08:31 2002
>And the corresponding output of "tail -f /var/log/messages"
>	kernel: CSLIP: code copyright 1989 Regents of the University of California
>	kernel: PPP generic driver version 2.4.1
>	pppd[1955]: pppd 2.4.1 started by root, uid 0
>	pppd[1955]: Using interface ppp0
>	pppd[1955]: Connect: ppp0 <--> /dev/ttyLT0
>	kernel: PPP BSD Compression module registered
>	kernel: PPP Deflate Compression module registered
>	N4206624 pppd[1955]: local  IP address
>	N4206624 pppd[1955]: remote IP address
>	pppd[1955]: primary   DNS address
>	pppd[1955]: secondary DNS address  (*)
>(*) The last two lines are shown if you add the line "usepeerdns" in /etc/ppp/options
>as suggested by Emin Liman when I raised a DNS issue in discuss@linmodem.org.
>However when connected:
>---------------------- >I did not get name server resolution after this, that is >I could ping using dotted quad notation IP addresses, >but domain name server (DNS) addressing failed. > >Even adding the two DNS addresses to /etc/ppp/resolv.conf was unsuccessfull. >The only solution I found was to prepare a specific DNS configuration file for >the ISP account (e.g. resolv.conf.libero) and write a simple script to substitute >/etc/resolv.conf before the connection, then restoring the usual network configuration >upon exiting. >
>//Comment from MarvS
>If ethernet is not "ifdown eth0" before attempting ppp without the further configuration
>work described below, there are frequently Netscape crashes and/or freezing of Xwindows
>Setting up name server resolution with kppp
>Setting up kppp is easily done by starting the tool and clicking on setup, >the various steps are well documented in the manual that is accessible through the ? button. >This process creates a configuration file in ~/.kde/share/config/kppprc >listing all the accounts information.
>If you provide your ISP's domain name, DNS addresses and set the option:
> "Disable Existing DNS Seervers during Connection" >in the DNS section of kppp setup ~/.kde/share/config/kppprc >will include lines such as
>	DNS=,
>	.....
>	Domain=infinito.it
>	ExDNSDisabled=1
>Given this, DNS resolution (magically) works with out any need to touch /etc/resolv.conf.
>However, when I use kppp I get a weird message:
>	....modprobe: modprobe: Can't locate module ppp0
>	... kernel: CSLIP: code copyright 1989 Regents of the University of California
> ... >
>in /var/log/messages. This can be (inelegantly) removed by inserting "alias ppp0 off" in
>/etc/modules.conf. >
>Please consider that starting a serial connection on a public network >while logged onto a LAN raises severe security issues and should be avoided.
> >

Check out the latest SMS services @ http://www.linuxmail.org This allows you to send and receive SMS through your mailbox.

Powered by Outblaze

Reply to: