[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems getting D-Link DFE-530TX+ working ... among other things

Steven Luke wrote:
> I have been trying to install Debian (3.0) from ISOs I got off of
> [...]
> I can get through the entire boot process but eth0 is never
> recognized.

Debian 3.0 does not have any automatic hardware discovery program.
You have to tell it specifically what hardware your system contains.
The next version of Debian to release 'sarge' does include automatic
hardware discovery.  If you are adventurous you might try testing it.
But note that it is not yet released and is still under development.

> I had tried to use the debconf configuration to recognize the eth0,
> but it doesn't work.

You have to know where to look.  Page down to:

  kernel/drivers/net        Drivers for network interface

Then select that and page down to:

  8139too                   RealTek RTL-8139 PCI Fast Ethernet Adapter support

Select that.  It should load the driver and place the name in
/etc/modules so that it is loaded automatically at boot thereafter.

> compile.  Is there anywhere I can get a pre-compiled Debian driver
> for this ethernet adapter?  The file is rtl8139.c for the D-Link
> DFE-530TX+.

The rtl8139 is Donald Becker's Driver.  A fine driver.  But the one
that made it into Linus' kernel tree for better or worse is the
8139too driver.  Since the RealTek is a popular and cheap low end
network card this is a common confusion.

> On the other hand, if I install Debian using the bf24 option on the

Oh!  I see now that you were not using the linux 2.4 kernel but were
using the linux 2.2 kernel.  What I said above applies to 2.4 and I
have forgotten all knowledge of the 2.2 kernel years ago.

> boot: prompt, the ethernet card is recognized, I can get updated
> packages via ftp, and can connect to servers from other computers.

The 8139too is compiled into the Debian bf24 kernel.  You can tell
this by looking at the config file for it.

  grep CONFIG_8139TOO= /boot/config-2.4.18-bf2.4

Since it is compiled into that kernel you do not need to add it as a
module.  And you can't load a module since when compiled into the
kernel no separate module is built.

> But (there is always a but), I can not get the XServer installed.

I cannot think of any reason changing kernels would affect the
installation of the X server which is in the xserver-xfree86 package.

> In the TaskSel screen the X Sever option never appears (though
> Desktop Environment does).  It doesn't appear in the dselect screens
> either.  If I install Gnome or KDE I get an error that it could not
> connect to the X Server, and when I ask it to show the Server
> output, there is none.  (also, I can't get APT to work in this
> install,but I haven't tried apt more than once...)

I will guess it is probably not being presented because it can't get a
list of packages from the network and so does not know about it.

> As far as I can tell, fixing either one of these problems would
> really help me out.  Can I get the ethernet card to work with the
> default install type, or get X Server to work with the bf24 install?

Try this:

  apt-get install x-window-system-core xterm

Then select your window manager.  Without getting into a window
manager debate, KDE is one option.  (I use FVWM myself.  But KDE seems
easier for new folk.)  If you are running stable then KDE there is
2.2.2.  I have been installing kde 3.1.4 from kde.org which was very
reliable.  kde.org recently released kde 3.2.  It is a little more
rough but good enough.  Put this in your /etc/apt/sources.list file
and you can install kde 3.2 from kde.org.  Or change that to 3.1.4 if
you desire the more tested version.  If you are running debian
unstable this is not needed since 3.2 is already in debian.org's
unstable.  This is only needed if you desire to use the backport to

  deb http://download.kde.org/stable/3.2/Debian stable main


  apt-get install arts kdelibs kdebase kdeaddons kdeartwork kdeutils kdemultimedia kdenetwork kdetoys kdm


Attachment: pgpzxq0rPgYhX.pgp
Description: PGP signature

Reply to: