[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian put into a broken state

On Thursday 01 April 2004 12:00 pm, Alan Chandler wrote:
> On Thursday 01 April 2004 20:39, Sean O'Dell wrote:
> > I'm new to Debian, and this morning I put a half-way finished
> > installation into a broken state and I can't figure out how to get it
> > back on track.
> >
> > Basically, I was trying to get a KDE machine working, and this morning I
> > added non-free and contrib to my sources.list file so I could install the
> > nvidia driver.  I had the machine working primitively with
> > networking+dhcpcd working, but KDE wasn't running yet because I needed to
> > install the nvidia driver.  I had both testing and unstable sources in
> > sources.list in order to get KDE 3.2 installed.  After adding non-free
> > and contrib to my sources this morning, I ran apt-get update,
> > dist-upgrade and upgrade, then apt-get install nvidia-glx.  I rebooted
> > the system after that
> Its been a while since I worked with the nvidia drivers, but don't you have
> to build them from source once you've downloaded the debian package?

I honestly don't know...I never got far enough to see what the nvidia-glx 
package I installed would do.  After I installed it, I rebooted to see what 
state everything would be in and it ended up in a broken state.

> > to see how it would all go, and at that point, things were pretty funky.
> >
> > eth0 isn't up, I can't get dhcpcd to start, and now I can't even get kdm
> > to
> What happened when the should have started - was there any error on the
> console?

Basically, it booted up pretty quietly.  I got a console, but ifconfig 
reported only lo being initialized.  eth0 was never brought up.

> > report anything in /var/log/kdm.log nor XFree86 to report anything in
> > /var/log/XFree86.0.log...they apparently both die before they can even
> > log anything.
> XFree86.0.log is the day old log.  Is there no new log.  Did X even try to
> start?

It doesn't look like it to me.  When I run /etc/init.d/kdm start, I get 
nothing printing to the console, no new XFree86.0.log and no kde.log files.  
It just dies quickly and quietly.

> > What should I do to get things straightened back out?  What did I do to
> > get things into this state?
> >
> > Just in case, I've included my /etc/apt/sources.list file.  Is there
> > anything else I should provide for reference?
> Need much clearer description of exactly what happened during start up. 
> Are you left with a login prompt on the text console?

It just boots up very quietly and quickly.  The only error I get is Alsa is 
unhappy with something (I think a module isn't installed that it wants), but 
everything else goes okay.  I get no errors reported about eth0 not coming 
up, and no errors in /var/log/messages.  XFree86.0.log and kdm.log don't even 
exist anymore...everything related to XFree86 and KDE dies before any log 
files can be generated.  dhcpcd is still installed...it just doesn't 
initialize eth0.

I wish I knew what else to report.  After the dist-upgrade, upgrade and 
installing nvidia-glx, it just went into this funky state and I can't figure 
out how to roll it back to where the network would at least initialize.

	Sean O'Dell

Reply to: