[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gdm login problem - Solved

On Thu, Mar 25, 2004 at 08:23:43AM -0500, Thomas H. George wrote:
> Suddenly I can no longer login to gdm.  When I enter my user name the
> screen goes blank then returns to the login screen.  I created an new
> user and when I tried to log in as this user the screen went blank after
> I entered the new user's password.  I still can login at any of the
> terminal screens with either my user name and password or the new user's
> name and password.
> At one point there was a message /dev/null permission denied.  The
> permissions were 666 which seemed like it should be ok to read and write
> to /dev/null but I changed them to 777 to be sure.  Then I no longer got
> the message but the logins failed as above.
> Anyone know what I have messed up?
> Tom
My fault.  I was trying to get workbone working again, I was getting a
message to change the permissions to cdrom with chmod 666 /dev/cdrom.
When I ran this a root and the ll /dev/cdrom the permissions were
unchanged.  Eventually I read the chmod man page carefully enough to
learn that since cdrom was a soft link to hdc the chmod command changed
the permissions of hdc, not cdrom.

While working this out I must have inadvertantly changed the permissions
to the dev directory.  Today, going carefully over all the permissions
with a clear understanding of what I was doing I found and corrected the

Well, almost a clear understanding - yesterday neither workbone nor
setmixer was working.  First I got setmixer working then tackled the
workbone problem.  Now workbone is working but setmixer -V again gives the
message, "error opening /dev/mixer." with 755 permissions.  I'll work on


> -- 
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: