[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apache cannot load libphp4.so

I have installed on an old pentium machine the woody base system and
packets mysql apache and php4 upon it.
Shortly after I have realized that apache was not executing the php
code. I found a README.debian which explained how to manually configure
apache to make it execute php code. In particular I commented out the
following instruction:
LoadModule php4_module /usr/lib/apache/1.3/libphp4.so

After that apache gave the following error and aborted:
Starting web server: apacheSyntax error on line 241 of
/etc/apache/httpd.conf: Cannot load /usr/lib/apache/1.3/libphp4.so into
server: /usr/lib/apache/1.3/libphp4.so: undefined symbol:

The file path is correct and libphp4.so is on my hard disk. On my laptop
with woody apache does _not_ produce any error and the php4
module is loaded into apache server normally.
Both machines have the same kernel 2.4.24 compiled by myself with no
patches. On the pentium machine the kernel is compiled with no loadable
kernel modules. I have tried to boot the pentium machine using the
2.4.18bf24 kernel of debian cds, with the same result.
Any suggestion to explain what is to me a complete mistery?
Saluti, Mauro.
On this laptop no Windows system survives and LINUX POWER reigns UNLIMITED.
GnuPG key ID: 28A61681

Reply to: