[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: md: can not impport hdb1, has active inodes!

On Wednesday 03 March 2004 09:54, Chris Evans wrote:
> I thought I'd got this all cracked in the early hours of this
> morning.  I _think_ I'd been putting boot=/dev/hda1 when I tried to
> write the revised lilo config to the MBR and perhaps that messed up
> hdb.  I don't know, anyway, I started again, did everything in that
> howto pretty much to the letter and this time, after shifting boot to
> /dev/hdc and rebooting, I could add /dev/hdb1.  However, lilo would
> not let me use a raid-extra-boot line and when I rebooted, the system
> hung right at the start.
> I moved hdb1 to hda1 and started again, this time it's all worked
> except for boot=/dev/md0 and the raid-extra-boot.  Now lilo allows
> these and says it's written to both MBRs, but when I reboot lilo gets
> to the first twenty or so of the dots after "Loading Linux" and hangs
> there ... resolutely.
> A lot of pratting around with rescuing from the installation CD (must
> work out how to burn a rescue boot CDROM) and I am back to being able
> to get everything find if I boot from boot=/dev/hdc with
> root=/dev/md0 ... and I think I'll give up here as I must go back to
> doing my real job and having a life.  If anyone can tell me what
> might be neeeded (I haven't tried things like bios=0x80 lines) I may
> find the energy to try them but not if this machine has become my
> working firewall!
> So I'm left thinking there's something, perhaps idiosyncratic to some
> BIOS or HDs or whatever, that means some of us have real problems
> writing LILO boot instructions to the two drives in a RAID1 boot
> array.
One question on your kernel hang: are you loading the same kernel 
successfully when you boot directly off /dev/hdc?  If not, do you know your 
kernel is good?

Since one of your disks is larger than the other, you might consider using a 
20 MB portion of the larger disk as a /boot partition, and keeping it out 
of the raid.  Booting will be very easy in that scenario, and you can use 
the rest of the disk for the raid, and put everything else on it.

If you still want /boot on the raid device, I can tell you that you don't 
need the raid-extra-boot line in lilo.  My box doesn't use it.  The other 
thing that is different is that my box has two raid devices, one for / and 
the other for /boot.  That should not matter, though.

[snip SuSE lilo.conf]

Reply to: