[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Grub/Lilo problems

I'm still kind of newbie, so, please, be careful about by tips, but maybe this will help:

Grub and lilo are alike in the sense that both (can) install code to the Master Boot Record to (be loaded by the bios at startup and) automate the boot process. Such boot code would not be affected by uninstalling the tool, so boot would be untouched. Grub and lilo are different, however in one aspect: every time you change something in you boot settings with lilo (edit lilo.conf), you need to run lilo again, to write such info to the MBR - and you will not be able to do that after uninstalling lilo - while grub can reach its config files in the filesystem during boot. Since grub is filesystem aware, once it is installed, working in the config files will be enough.

If you have a grub prompt at boot, even if lilo is installed, its boot code was not written to te MBR, but you are still halfways with grub. Take a look at grub docs, edit grub.conf, and that will do the trick. Or, check out lilo.conf, run lilo to write MBR data.

There's a catch, anyway: knoppix gives you a complete RAM based working environment, so you must to sure that you're working in the real HD filesytem (find the right partition, mount it read/write, and maybe, chroot to it) to make all this work.


paulsmith20378@ntlworld.com wrote:

I know this isn't a knoppix list, but it's debian based, and I'm not having much luck at other places. Hope you can help :)

I made a new computer (yay), and proceeded install the Fedora Core. After playing with it for a little while, I thought "No, I don't think so", and did a hard disk install of my trusted knoppix CD (which served me so well in the past). Everything was fine until reboot time, when it booted into grub, and stayed there. No kernel or os booted, I just got this grub prompt. It goes into Debian when I use the boot floppy, but not when it boots from hd. I'm assuming this is because Fedora wrote a boot sector that wasn't deleted by the knoppix install.
I know that lilo installed.

I tried looking into fdisk and cfdisk to see if I could wipe the hd and start again, but I wasn't able to figure our how to reformat a partition. I mean completely wipe it.

I also tried uninstalling grub using dselect. I assume that the grub that I uninstalled was a debian grub, not the one that is booting my system.
Is there an easy way to make the hd blank, as new, so that I can install knoppix again? Or a way to make lilo boot instead of this grub thing?

Sorry if you've heard this question a hundered times before. Being a convert from windows, I'm not completely up with a lot of the terminal commands. Although it does seem a lot quicker than doing things via a gui

Email provided by http://www.ntlhome.com/

Reply to: