[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Screen fonts in X


	Just installed Debian 3.0 r.0 from CD (No internet connection, I
know 3.0 is at r2).  Fonts are very fuzzy.  Title bars are unreadable,
text in a terminal window is, but not for very long, menus can be used
too, but very hard on the eyes.

	I've looked in the archives.  I'm forced to do my searches on time
limited public terminals at the moment, so what I've found so far comes
from threads in May 2003 principally:

	- I've tried reordering the font path in both XF86Config-4 and
/etc/X11/fs/config (or something like that) to no avail (stopping and
restarting xfs or xdm as the case warranted;

	- dpkg-reconfigure fontconfig in order to allow bitmapped fonts,
but the command complained it didn't know what fontconfig was (neither do
I, but that was the suggestion in one of the threads;

	- made sure I had freetype installed and that the module was being
called for loading in XF86Config-4

	- Checked the  /var/log/XFree86.+.log logs finding nothing

	- I tried a couple of other dpkg-reconfigure suggestions, but the
notes I've brought with me for this email aren't as good as I thought, so
I can't remember what they were [he added lamely].

	Any guesses ?  Hmmm, as I write, I realize that I didn't change
font orders for X and for xfs simultaneously (the font orders would be
different between files in my tests)  would this matter?  I must admit
that I don't understand very well how fonts work in X, especially since
font serving was introduced, so I don't even know which file is being used
if only one is, though I did try shutting down the font server totally for
a couple of tests.

	I even attempted to remove the xfs package since one of the
threads I found wondered out loud why people even ran them.  Since X had
this functionality built in now, an external server was really needed
except for special fonts.  But I was warned that X depended on xfs so I
backed out of making that change.

	I realize that I haven't done a very complete archive search yet,
but that is a real pain in the butt using heavily used public machines.

	ONe thing I did not in the X output was that PEX fonts couldn't be
found.  Sure enough xfonts-pex is not on the CD I have.  Could this be the

	I'd love to send the X output logs but can't use floppies from
these terminals.  If there is anything that needs to be checked, though, I
will find a way to post it.  There were a few glitches with some modules
(DRI, hal, mga).

	Any help welcome.  I"d really like to get X usable as soon as
possible.  I've been switching to a VT to scoure the docs available with
the install because its just too painful to read in X at the moment.


G. Crimp

Reply to: