[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

New Debian install + Rocket133 = no HDDs! (Please help this Debian newbie! Thanks!)



Hello all:

+-----------------------------------------------------------------+
| This post is an UPDATE to my prior post, with more information! |
|             This post supercedes the original one.              |
+-----------------------------------------------------------------+

             Please help this newbie, PLEEEEASE!

Background:
-----------
I started with Linux by using Red Hat on my desktop/workstation for
about a year now (RH7.2, 8.0, 9) and I've been slowly learning about
Linux in the process.  After Red Hat announced their new business
direction, I decided that I wanted to migrate to Debian.  Debian
always sounded cool, now I have the motivation.  I want to install
Debian on an old computer to act as a low-load server, and *then*
migrate my workstation to Debian (it is actually somewhat
"mission-critical", so I need to be more comfortable with Debian
before Debian-izing it).

The old computer that I want to make a simple file server is a
PentiumII-350MHz (100MHz FSB).  I just bought two Seagate 80GB drives
to put in it, and I also purchased a "Highpoint Rocket133" IDE
controller with the hope that it might result in faster disk access
than that of the old, on-board controller (I really don't know this
for sure, but it *seems* reasonable).  The Seagate 80 GBs are ATA100,
by the way.  There are no other HDDs in the machine, and just a CD-ROM
on the original IDE cable and a NIC; I wanted to use the two Seagate
80-Gigs in a RAID-1 configuration (for the majority of the disk-space,
anyway).

Problem:
--------
I tried to install Debian on this "2-HDD-on-the-Rocket133" system, and
Debian complains that it can't find any HDDs, and tells me that this
better be a disk-less NFS install, or I need to load modules to allow
Debian to "see" any HDDs.  This is from attempting to boot as "bf24"
(I also tried "compact" and "vanilla").

Well, the first thing I did was punt!  I tried to install Red Hat 9,
and EVERYTHING WORKED FINE!  <:-/  RH saw the two disks, and I went
ahead and partitioned them as follows:

   /dev/hde1:  /boot    100 MB
   /dev/hde2:  /var    8000 MB
   /dev/hde3:  <swap>   800 MB

   /dev/hdg1:  <swap>   800 MB
   /dev/hdg2:  /tmp     100 MB
   /dev/hdg3:  /usr    8000 MB

   /dev/hde4/5:  RAID1
   /dev/hdg4/5:  RAID1
   Resulting in:
   /dev/md0: ~70 GB  RAID1  hde5[0] hdg5[1] [2/2][UU]

My hope was that with the two HDDs now partitioned and
'filesystem-ed', Debian would recognize them.  Well, NO BANANA!  The
Debian install still tells me that there are no HDDs!

I've searched the archives for some information, and I haven't found
much.  I've found information about trying to use cheap Highpoint H/W
"RAID" controllers, but this isn't a RAID controller---it's just
another IDE controller (although the boot messages about the card
sometimes seem to *imply* RAID in some way).  I also found someone who
couldn't get Debian to see his HDDs on another controller, but his
solution was to boot the 2.4 kernel with "bf24"---but I've been trying
that.  Additionally, I've seen advice about recompiling with certain
kernel options to support *other* controllers, but I have two problems
in this arena: (1) I've never compiled a kernel myself, and (2) on a
brand-new install like this, I can't do anything *about* the kernel,
can I?

After wading through many, many messages in the archives---I found
something *similar* (getting HDDs recognized on the another
controller) that involved passing arguments to the kernel on boot.
So, after looking at the sample in the archive---and the address/IRQ
information from my successful RH install (below)---I tried the
following permutations at the Debian install boot prompt:

   bf24  ide2=0x2050,0x2062  ide3=0x2058,0x2066

   bf24  ide2=0x2050,0x2062,11  ide3=0x2058,0x2066,11

   bf24  ide2=0x2050-0x2057,0x2062  ide3=0x2058-0x205F,0x2066

   bf24  ide2=0x2050-0x2057,0x2062,11  ide3=0x2058-0x205F,0x2066,11

Some of these get *close*---it *seems*.  On at least one of the above
combinations, I saw boot messages pass by quickly that *looked* like
the kernel had successfully read the "hde" and "hdg" HDDs.  But, alas,
three screens later it informed me that I didn't have and HDDs!  I
also saw something about the "HPT302" being recognized, but I can't
give you the exact messages, because they scroll by, and I don't know
how to stop them or save them on an install like this!


So, anyway, I got the information that I tried above from booting back
into the newly-installed RH9 system, and trying to look at anything
that I thought might be valuable (more for the experts than for me!
;-)  What I found is below.

Any help would be *greatly* appreciated!
Thanks-in-advance,
Bruce.

----------------------------------------------------------------------
Red Hat *successful* install information (for reference for Debian):
----------------------------------------------------------------------
#dmesg | less
   :
   HPT302: IDE controller at PCI slot 00:10.0
   :
   PCI: Found IRQ 11 for device 00:10.0
   PCI: Sharing IRQ 11 with 00:14.2  (<--this looks to me to be USB)
   :
   HPT302: Chipset version 1
   HPT302: Not 100% native mode: will probe IRQs later
   HPT37X: Using 33MHz PCI clock
      ide2: BM-DMA at 0x2400-0x2407, BIOS settings: hde:DMA, hdf:PIO
      ide3: BM-DMA at 0x2408-0x240F, BIOS settings: hdg:DMA, hdh:PIO
   :
   hde: ST380011A, ATA disk drive (<--Seagate 80GB #1)
   :
   hdg: ST380011A, ATA disk drive (<--Seagate 80GB #2)
   :
   ide2 at 0x2050-0x2057, 0x2062 on IRQ 11
   ide3 at 0x2058-0x205F, 0x2066 on IRQ 11
   :
   hde: host protected area => 1
   :
----------------------------------------------------------------------
#cat /proc/version
   2.4.20-8 ...RH Linux...
----------------------------------------------------------------------
#cat /proc/pci
   :
   bus 0, device 16, function 0:
      RAID bus controller: Triones Technologies, Inc. HPT302 (Rev.1)
      IRQ 11
      master capable.  latency=120.  min.gnt=8. max.lat.=8
      I/O at 0x2050 [0x2057]
      I/O at 0x2060 [0x2063]
      I/O at 0x2058 [0x205F]
      I/O at 0x2064 [0x2057]
      I/O at 0x2400 [0x24FF]
----------------------------------------------------------------------
#cat /proc/modules:
   used: parport_pc, parport, e100, usbcore, ext3, usb, RAID1
   unused: msr, lp, autofs, keybdev, mousedev, hid, input, usb-uhci
----------------------------------------------------------------------
#cat /proc/ioports
   2050-2057: Triones Tech ... HPT203
            : ide2
   2058-205F: Triones Tech ... HPT203
            : ide3
   2060: ...ide2
   2064: ...ide3
   2400: ...ide2
   2408: ...ide3
   :
----------------------------------------------------------------------

If you read this far, *really* thanks!  ;-)
Bruce.

--
  _________ Maguire@AnalyticInvestments.com ________ |**===
 /                                                   |**===
(  W. B. Maguire II, Ph.D.    Tel: 303.772.1615      |=====
|  Chief Executive Manager    FAX: 303.651.6389    9||
|  Analytic Investments LLC           _                   |
|  700 Ken Pratt Blvd STE204 PMB166  ( ) The ASCII ribbon |
(  Longmont  CO  80501-6455           X  campaign against )
 \__________________________________ / \ _ HTML e-mail __/



Reply to: