[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Help! New Debian install + Rocket133 = no HDDs!

Hello all:

This is my very first post, and I only just subscribed, so be gentle!  ;-)

I've been using Red Hat on my desktop for about a year, slowly learning
about Linux in the process.  After Red Hat announced their new business
direction, I decided that I wanted to migrate to Debian.  I still have
RH9 on my desktop, but I wanted to install Debian on an old computer
to act as a low-load server, and then migrate my desktop to Debian (my
desktop is actually somewhat mission-critical for my business, so I
want to really be comfortable before changing it from RH to Debian).

I would like to use an old computer that I have as a file server; it
is a PII-350 with a 100MHz FSB.  I just bought two Seagate 80GB drives
to put in it, and I went ahead and purchased a "Highpoint Rocket133"
IDE controller, because I thought it might result in faster disk
access than what the old, on-board controller would (I don't know this
for sure, but it *seems* reasonable).  The Seagate 80s are ATA100, by
the way.  So there are no other HDDs in the machine, and just a CD-ROM
on the original IDE cable; I wanted to use the two Seagate 80s in a
RAID-1 configuration (for the majority of the disks, anyway).

I tried to install Debian on this 2-HDD-Rocket133 system, and Debian
complains that it can't find any HDDs, and tells me that this better
be a disk-less NFS install, or I need to load modules to allow Debian
to "see" any HDDs.

Well, the first thing I did was punt!  I tried to install Red Hat 9,
and everything worked great!  RH saw the two disks, and I went ahead
and partitioned them as follows:
   /dev/hde1:  /boot    100 MB
   /dev/hde2:  /var    8000 MB
   /dev/hde3:  <swap>   800 MB

   /dev/hdg1:  <swap>   800 MB
   /dev/hdg2:  /tmp     100 MB
   /dev/hdg3:  /usr    8000 MB

   /dev/md0: ~70 GB  RAID1  hde5[0] hdg5[1] [2/2][UU]

My hope was that with the disks partitioned and filesystem-ed, Debain
would recognize them.  Well, no banana!  The Debian install still told
me that there were no HDDs.

I've searched the archives for some information, and I've really only
found information about trying to use cheap H/W "RAID" controllers.
But this isn't a RAID controller, just another IDE controller.
Additionally, I've seen advice about recompiling with certain kernel
options, but I have two problems in this arena: (1) I've never
compiled a kernel myself, and (2) on a brand-new install like this, I
can't do anything *about* the kernel, can I?

I booted back into the newly-installed RH9 system, and got some
information that I had hoped might help clarify my problem, or the

Any help would be *greatly* appreciated!

Red Hat *successful* install information:
#dmesg | less
   HPT302: IDE controller at PCI slot 00:10.0
   PCI: Found IRQ 11 for device 00:10.0
   PCI: Sharing IRQ 11 with 00:14.2  (<--this looks to me to be USB)
   HPT302: Chipset version 1
   HPT302: Not 100% native mode: will probe IRQs later
   HPT37X: Using 33MHz PCI clock
      ide2: BM-DMA at 0x2400-0x2407, BIOS settings: hde:DMA, hdf:PIO
      ide3: BM-DMA at 0x2408-0x240F, BIOS settings: hdg:DMA, hdh:PIO
   hde: ST380011A, ATA disk drive (<--Seagate 80GB #1)
   hdg: ST380011A, ATA disk drive (<--Seagate 80GB #2)
   ide2 at 0x2050-0x2057, 0x2062 on IRQ 11
   ide3 at 0x2058-0x205F, 0x2066 on IRQ 11
   hde: host protected area => 1
#cat /proc/version
   2.4.20-8 ...RH Linux...
#cat /proc/pci
   bus 0, device 16, function 0:
      RAID bus controller: Triones Technologies, Inc. HPT302 (Rev.1)
      IRQ 11
      master capable.  latency=120.  min.gnt=8. max.lat.=8
      I/O at 0x2050 [0x2057]
      I/O at 0x2060 [0x2063]
      I/O at 0x2058 [0x205F]
      I/O at 0x2064 [0x2057]
      I/O at 0x2400 [0x24FF]
#cat /proc/modules:
   used: parport_pc, parport, e100, usbcore, ext3, usb, RAID1
   unused: msr, lp, autofs, keybdev, mousedev, hid, input, usb-uhci
#cat /proc/ioports
   2050-2057: Triones Tech ... HPT203
            : ide2
   2058-205F: Triones Tech ... HPT203
            : ide3
   2060: ...ide2
   2064: ...ide3
   2400: ...ide2
   2408: ...ide3

If you read this far, *really* thanks!  ;-)
  _________ Maguire@AnalyticInvestments.com ________ |**===
 /                                                   |**===
(  W. B. Maguire II, Ph.D.    Tel: 303.772.1615      |=====
|  Chief Executive Manager    FAX: 303.651.6389    9||
|  Analytic Investments LLC           _                   |
|  700 Ken Pratt Blvd STE204 PMB166  ( ) The ASCII ribbon |
(  Longmont  CO  80501-6455           X  campaign against )
 \__________________________________ / \ _ HTML e-mail __/

Reply to: