[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

laptop, dhcp and ADSL

  Hello. This is a rather long mail. I've been struggling against
network configurations in my laptop this week, to get ADSL working at
home. I have succeeded, but after several failed trials. Maybe someone
here can help me understand?

  First: my laptop is a Compaq Armada 7800, with sid running, and a xircom
pcmcia card. My ADSL provider (KDDI, in Japan) sent me an NEC ATerm
WD605CV modem.

  The first I tried was using pppoeconf (previously disabling the
static IP configuration in /etc/network/interfaces and restarting
the network). Nothing. pppoeconf saw eth0, but could not establish a
connection ("Your access concentrator did not respond", and asking me
to check wiring, or saying maybe some other process was using
pppoe.). After a lot of googling I learned maybe dhclient would work,
and it did! So now 'dhclient eth0' gets me an IP number and I have
network. Does it mean that this modem (although always refered to as
"modem" in the japanese documentation ---at least I can recognize that
word) is indeed a router, and that pppoeconf was never the way to go?

  The other thing I  don't understand is that I never gave it my
password and username. (Al least with the sid machine. I had tried
before with a windows laptop, to check whether it was a wiring
problem. I went through the install process, and at some time it asked
me username and password. Could it make any difference, in the sense
that the modem now knew that I was me, and then it didn't mind if I
changed the computer? Or it is not so smart?)

  Later I tried to set up things at boot time, so that my wife could
browse the web. More googling. a) Maybe leaving a line for eth0 in
network/interfaces, but changing static->dhcp? Didn't work.  b) Maybe
adding 'dhclient eth0' at the end of /etc/init.d/bootmisc.sh?  No. It
complained at boot time, and later I learned this was due to network
services being set up after bootup. c) Ok. Changing DHCP="n" -> "y" in
/etc/pcmci/network.opts, which seems the right thing to do according
to documentation in doc/pcmcia-cs/? No. I tried this with and without
lines such as 'iface eth0 inet dhcp' in network/interfaces. d)
Installed laptop-net, which asked me at configuration time whether I
would use dhcp. I said yes. I would look at the config files in
/etc/laptop-net/, and they looked fine, setting all schemes except
'offline' to use dhcp. More reboots. Nothing. Since dhcp is supposed
to give me dynamic IPs, I didn't try to set scheme configuration
automatically from IP, at least for a start, but I understand that
this is optional, so it should have worked anyway.

  In the end, I installed sudo, gave permission to my wife to run
dhclient, and that's it. She can browse the web.

  Now, there's one further problem ahead: The adsl service includes a
voice over IP service. I don't know how to use it (documentation is in
japanese!), but, just to see if I could set up something like that
now, I tried connecting to the modem via http (http://web.setup), and
the modem, correctly, asked for my username and password. But it never
recognizes them. I tried with Mozilla, and then with Opera (identifing
itself as MSIE), and nothing. Is it possible that the modem setup can
only be accessed with certain browsers? Unfortunately, this provider
does not support Linux explicitly, although they've been very kind to
answer my questions. But I've seen this same modem used by providers
supporting Linux as well, so I wouldn't think there's some built
in restriction in the modem. Anyway, I don't know much about these
things, so I'm just guessing.

  Right. Enough questions. I'd be glad to hear any ideas about
it. Luckily, I have network working at home, but as I said, I'd like
to understand a little what's going on.



Reply to: