[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: soundless in kazaa]

On Mon, Dec 22, 2003 at 05:33:25PM -0500, Sam Rosenfeld wrote:
> ----- Forwarded message from Sam Rosenfeld <sam@wdn.com> -----
> On Fri, Dec 19, 2003 at 04:49:43PM +0200, Micha Feigin wrote:
> > On Thu, Dec 18, 2003 at 09:51:59PM -0500, Sam Rosenfeld wrote:
> > > I installed Debian Woody about 6 months ago and to my knowledge have
> > > not experienced sound since then, with one exception:  In using either
> > > isapnptools or ALSA a test responded with a sound.  I have tried from
> > > time to time to resurrect sound so that I could listen to music CDs on
> > > my CD-Rom etc. but I haven't been able to.  
> > > 
> > >  
> > > sam
> > 
> > packages.debian.org is down at the moment so I don't know what kernels
> > are available in stable (woody), I think that these are the same
> > options.
> > You don't need to recompile the kernel in order to install alsa. If you
> > want to build the modules yourself, you will need to configure it
> > though.
> > To get the precompiled modules you will need the alsa-modules
> > package. On unstable seems to only be a version for 2.4.22, so if you
> > don't have a problem with running 2.4.22 on that computer (you should
> > probably switch to 2.4.23 when the packages will be available)
> > you will need alsa-modules-2.4.22-1-k6 and kernel-image-2.4.22-1-k6.
> The most recent package I can easily get is: alsa-modules-2.4.16-k6,
> which includes the kernel-image-2.4.16-k6 as a dependency.
> I 'apt-get install'ed the alsa-modules pkg and during the installation
> of the kernel-image package it stopped and asked me to 'add
> initrd=/initrd to my /etc/lilo.conf file.  I already had an /initrd
> link to a file in my /boot directory.  When I tried to run lilo after
> changing the lilo.conf file, it balked and gave me a cryptic error
> message (which I didn't write down).  When I tried to resume the
> installation of the alsa-modules package, the process was halted and
> exited.  What is all that about the initrd entry into lili.conf?
> Thanks.
> sam

Don't remember the exact syntax, but initrd is a cramfs file system
which holds kernel drivers you may need before the partition holding
the drivers is mounted (usually /lib/modules on root).
It will usually among other thing hold the drivers for your root
partition. The idea is that the kernel can't access the root partition
to get the drivers needed in order to mount it.
lilo need to know where it is since like I managed to explain very
badly, the kernel doesn't know where to look in order to read it
Personally I am not very clear as to the advantages of initrd and never
used it (the stock compiled debian kernels except for bf2.5 if I recall
all use it). The only advantage I can see is for general purpose
kernels where you don't want to compile all the file system modules
into the kernel or maybe for network boots where root is mounted over a
> > You'll probably also want alsaconf to configure it.
> > I'm not sure if both of these are needed or just one but you'll
> > next to do
> > ln -s /etc/alsa/modutils/0.9 /etc/modprobe.d/alsa
> > ln -s /etc/alsa/modutils/0.9 /etc/modutils/alsa
> > 
> > and then update modules. Next try /etc/init.d/alsa restart and see if
> > that works.
> > If this fails somewhere post the problem and error messages.
> ----- End forwarded message -----
> -- 
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: