[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trying to boot after Debian installer ran

Damon L. Chesser wrote:
I have run the debian installer, installed a base system, chose the default LILO install choice. The installer did NOT wright (I watched the drive light to verify this, it SHOULD have written) to the disk, system re-booted. I have mounted the Debian partitions to examine them. Debian root = hdb6 with /boot as a sub dir. Here is the contents of Debian /boot:

user1@DAM-LN:/mnt/Debianboot/boot$ ls -l
total 4568
-rw-r--r-- 1 root root 518609 Oct 3 23:59 System.map-2.4.22-1-386
-rw-r--r--    1 root     root          512 Dec 14 09:46 boot.0340
-rw-r--r--    1 root     root        42261 Sep 27 03:17 config-2.4.22-1-386
-rw-r--r-- 1 root root 3264512 Dec 14 09:45 initrd.img-2.4.22-1-386
-rw-------    1 root     root        53760 Dec 14 09:46 map
-rw-r--r-- 1 root root 769886 Oct 3 23:59 vmlinuz-2.4.22-1-386

Here is my grub menu.lst:

title        Libranet GNU/Linux, kernel 2.4.23 NEW
root        (hd0,5)
kernel /boot/vmlinuz-2.4.23 root=/dev/hda6 ro hdc=scsi hdd=scsi vga=792

title        Libranet GNU/Linux, kernel 2.4.23 (single user mode)
root        (hd0,5)
kernel /boot/vmlinuz-2.4.23 root=/dev/hda6 ro hdc=scsi hdd=scsi single

title        Debian GNU/Linux, kernel 2.4.22-1-386
root        (hd1,5)
kernel /boot/vmlinuz-2.4.22-1-386 root=/dev/hdb6 ro hdc=scsi hdd=scsi savedefault

The above Debain GNU/Linux entry will boot, but stops with an error message "cant find image, please amend root= entry to the correct root image" or words to that effect. Here is the question:

Given the above, how can I get Debian to boot? cd into the Debain / (while running Libranet) and run lilo? Modify in some unknown to me way the above grub entry?

I have removed the hdc=scsi entries. I have changed values for (hd1,5) and /dev/hdb6 on the chance that my understanding was flawed. I have found a different source for the iso image and downloaded/burned/loaded it. The Installer worked very well, except it seems to fail in allowing me access to my new shiny base system!!! Talk about security! The distro was sarge, ext3 was chosen for file systems, hdb6 /, hdb7 /home, hdb5 /var (as reiserfs). All partitions seem written to with out errors (as checked out from Libranet).


I don't know much about this. I used to have some similar problems which were solved by using the idebus option while booting

I used idebus=66

U might need to check the boot options for ur specific coniguration.


Reply to: