[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem Compiling kernel-source-2.4.18



Thomas H. George wrote:
My system is testing fully up-to-date. I just ran apt-get update and apt-get dist-upgrade which installed kernel-source-2.4.18.. My current kernel was built from kernel-source-2.4.22 but I have been experiencing irratic behavior - specifically many p80211/knetdev_hard-start_xinit: messages on shutdown followed by various problems on rebooting. Genrally a second reboot works. I decided to backup to kernel-2.4.18 in hopes of eliminating the problems.

After make menuconfig and make dep when I run make bzImage the compile aborts with a series of messages the first of which is in

In the file included from ksym.c:50:
/usr/src/kernel-source-2.4.18/include/asm/checksum.h:72:30: missing termintating " character


And is there a missing terminating character?
Checking I note that the line in question is:

	__asm__ __volatile__("

which indeed does have a missing " character.

If you are using gcc 3.3, which you are if you ran dist-upgrade, it *will* complain of that. You can apt-get install gcc-2.95 and that will do away with the error.

Also apt-get install kernel-package and instead do:

make-kpkg --revision 1 kernel_image

and that will create a deb file for you that is installable as the new kernel: it will do all that make dep for you.

I would not be afraid that the system is compromised until you really see something that is not of your own doing...

Hugo


I am concerned that the system is compromised. I have run chkrootkit and even tried chkrootkit -x SucKIT but chkrootkit doesn't know SucKIT.

I would appreciate any insights about the nature of the problems and what to do about them.

Tom






Reply to: