[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem Compiling kernel-source-2.4.18

My system is testing fully up-to-date. I just ran apt-get update and apt-get dist-upgrade which installed kernel-source-2.4.18.. My current kernel was built from kernel-source-2.4.22 but I have been experiencing irratic behavior - specifically many p80211/knetdev_hard-start_xinit: messages on shutdown followed by various problems on rebooting. Genrally a second reboot works. I decided to backup to kernel-2.4.18 in hopes of eliminating the problems.

After make menuconfig and make dep when I run make bzImage the compile aborts with a series of messages the first of which is in

In the file included from ksym.c:50:
/usr/src/kernel-source-2.4.18/include/asm/checksum.h:72:30: missing termintating " character

I am concerned that the system is compromised. I have run chkrootkit and even tried chkrootkit -x SucKIT but chkrootkit doesn't know SucKIT.

I would appreciate any insights about the nature of the problems and what to do about them.


Reply to: