[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg package "stuck"



Hello David!

On Thu, Nov 20, 2003 at 09:42:49AM +0000, David Selby wrote:
My dpkg database seems to be slightly corrupted with respect to the "imgsizer" package

If I try to install it I get:
[...]
dpkg: parse error, in file `/var/lib/dpkg/status' near line 55249 package `imgsizer':
missing version
E: Sub-process /usr/bin/dpkg returned an error code (2)
[...]
/var/lib/dpkg/ststus contains ....

 55244
 55245 Package: imgsizer
 55246 Status: purge ok installed
 55247 Priority: optional
 55248 Section: web
 55249
[...]

Hm, this looks OK to me.

Perhaps you could try to use one of the backups from /var/lib/dpkg/ or
even /var/backup/, ie. do a diff -u between your current status and a
backup, note the changes, if any, copy the backup over the current
file and redo, that is reinstall / remove, all changes.

Cheers,
Flo

Attachment: pgpSLj4tgrfdL.pgp
Description: PGP signature


Reply to: