[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: another problem starting X with sarge-install

Tom Allison wrote:
I did an install using the sarge install cd last night. I installed
the minimum software necessary. This went fine.

Then I ran TaskSel and selected only the X-Window-Server.

Initially there was an autodetect made of my hardware, including my video card, all of which went fine. It completely recognized my
video card and the memory available on my Matrox G400.  At what I
expect was the completion of the process, it started over again at
the beginning asking me about my Geniric Video Card and how much
memory it had.

Do you perhaps have two video cards in the system? Or is the G400

I assume this is an installation bug of the sarge-install process.

Installed and configured all of those packages and tested X. X worked
for both root and regular users.

I was able to login using xdm and get to a twm (default) desktop as
root and non-root users.

I then ran dselect, which selected a number of files by default. I
selected no other packages for installation except the package for msft fonts and continued with the install.

After this completed, I rebooted (new kernel) and was able to start
up xdm (did not start automatically).

Odd that it did not start automatically.

I could login using XDM to the WindowMaker desktop as root. As a
non-root user, my login failed and I was sent back to the XDM login screen.

Instead of using XDM, can you start X as a normal user with just the
"startx" command?

My first suspicion would be "/etc/X11/Xwrapper.config" having the line
"allowed_users=root" instead of "allowed_users=console". If so, you can
change it manually or run "dpkg-reconfigure xserver-common" and properly
answer the question about who can run X.

At this point I will retry installation of Debian using only -stable packages to see if this can be set up correctly with those packages.

Yikes! No need to reinstall. This is just an X issue, not an OS issue.


Reply to: