[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: install local deb file

Nick, thanks, but your second method (installing dependences first,
then the package that needs them) does not work for me. Here's what
I did. 

  # cd /storage/debs  // went to place where the .debs file is located  
  # ls                // I see listed libdb1-compat_2.1.3-7_i386.deb 
		      // and libc6_2.3.2-9_i386.deb 
  # apt-get update    
  Ign file: debs/ Release   // Is this a problem?
  # apt-get install libdb1-compat
  Reading Package Lists... Done
  Building Dependency Tree
  The following extra packages will be installed:
  The following NEW packages will be installed:
  1 packages upgraded, 1 newly installed, 0 to remove and 0 not
  Need to get 0B/3761kB of archives. After unpacking 160kB will be
  Do you want to continue? [Y/n]  // I continue
  Err file: debs/ libdb1-compat 2.1.3-7
      File not found
  Err file: debs/ libc6 2.3.2-9
      File not found
  Failed to fetch
	 File not found.
	 // I don't understand the syntax here. Is it looking in
	 // /storage/debs?
  Failed to fetch
	 File not found.
  E: Unable to fetch some archives, maybe run apt-get update or try
	 with --fix-missing?

In case the order was critical, I tried with the other file first, but
same results. 

The above suggests that apt is able to access the directory, see the
files it, but not access them. The files are owned by user, but the
command is run by root, so ownership not an issue. The files are
-rw-------. I assume they need only be readable. 

But another complication. The libc6 is an update, not a new
installation. So I tried apt-get upgrade libc6:

  The following packages have been kept back

I tried libc6=2.3.2-6, and got the same results as without the version


Reply to: