[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade->dead system, help.

Hmmm...interesting...i was starting to think it was all my doing while
all i really did was the usual update.
Sofar i haven't been able to figure it out..at all.
I've made a completely new 2.4.22 kernel, and the exact same thing happened, freeze after the INIT: version 2.85 booting message.
None of my older custom build 2.4.22 kernels will get past that point
either anymore.
2.4.18 and 2.2.19 go through the boot process without problems.
All the 2.4.22 kernels on my system have worked fine untill now.

Anyways..after that i installed the debian kernel package 2.4.22-686.
As a side note...that one uses an init.rd which none of my custom kernels did and this kernel does boot without problems.
Which is not to say that the problem is only there with non initrd
kernels, just thought i'd mention it.

I've not build a new custom kernel but plan to do so tomorrow, with
a freshly downloaded source, although i have little hope that one
will work.

I'm not a linux guru at all, which is why i hesitate to say this but
me thinketh something is buggy somewhere especially since i'm not
the only one having experienced this.
It happened to me Friday aswell by the way.

Since it happens when sysinit starts i'm inclined to think
something is amiss there, though i have no clue as to what and i'm not skilled enough to find out.


César wrote:
Last friday I had the same exact problem. I'll tell you if I guess a solution.

 wil <wsa3@xs4all.nl> wrote:


Sorry I have very little info on this...no logs or anything:(

Running SID, with a custom 2.4.22 kernel, ext3 file system.
HD was checked with the diagnostic utility from IBM, including
surface (advanced) check and was fine.

Did an update via dselect  yesterday and after that the whole
system has died. When i boot the process stops at
INIT: version 2.85 booting
followed by a blinking cursor.

When i ran the upgrade the thing striking me as very odd was
under "new packages to install" 'kernel-headers 2.5.x.x.' were
Not sure of the exact version anymore but it was 2.5 for sure.
I think it was 2.5.99.
I was kinda flabbergasted by that and saw no reason why those
kernel headers should be installed...since i'm on 2.4.
So i went back into the dselect selection 'mode' and set that
kernel package to 'purge' so it wouldn't install.
This gave me a load of 'xxxx depends on kernel-headers 2.5.x.x. ' like
from gcc and so on.
Struck me as utterly weird aswell cause my system never had anything
2.5.xxx kerlnel related stuff on it...anyways...thinking 'dpkg knows best' i let
it have it's way and the package in question was installed.
After getting the packages during install/configure something went wrong
aswell but silly me didn't pay too much attention since this happens
quite a lot with unstable and always gets resolved quickly...and
never ended in something like i'm having now.
Can't imagine the cause to be those kernel headers even if it's weird
they were installed, but one of the 20 orso packages which got

An older 2.4.18 kernel does go thru the entire boot process  but
with may many errors mostly in the line of 'can't find /var/xxxxxxxxxx'

After that i tried  toms floppy linux to boot the system.
mount /dev/hda9 results in just getting the'special device
not found message'.
And  hda9 happens to be /var. fdisk shows hda9 as there and
as ext3 but i think the complete filesystem went out da door on
that partition.
e2fsck gives me a  'the superbloack could not be read or does not....'

Any ideas on how to get out of this one?...and why this happened?


Reply to: