[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Network unreachable

On Sat, 2003-11-01 at 22:21, Jeffrey Barish wrote:
> When I use the kernel that I built from the source for 2.4.18-686, I get 
> the message:
> sendto: Network is unreachable
> when I try to ping another machine on my network.  Using ifconfig, I 
> noticed that eth0 had no IP address assigned.  So I did
> ifconfig eth0 down
> and then
> ifconfig eth0 netmask up
> At that point, ping worked.  So it seems as if dhcp is not working.  Is 
> there something in the kernel configuration that is required to make 
> dhcp work? 
> I am still not able to browse the web.  I get the message "Could not 
> connect to host ..." no matter what URL I use.

If you can ping yourself, then I think that means that the kernel
understands networking.  Sounds like a userland problem.  If you
boot using a different kernel, does it work ok?

Ron Johnson, Jr. ron.l.johnson@cox.net
Jefferson, LA USA

Note to LSU and Valdosta State students: India is not an Arab

Reply to: