[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PAM rejecting valid username/passwd ???



Michael D Schleif <mds@helices.org> [2003:11:01:08:58:14-0600] scribed:
> Michael D Schleif <mds@helices.org> [2003:10:31:19:19:32-0600] scribed:
> > It all started after rebooting to correct a scsi module problem ;<
> > 
> > My logon and email fetching has been working *without* incident for many
> > months.
> > 
> > Now, my user (mds) can no longer ssh into a remote debian system:
> > 
> >    # ssh -X deb.platinumaire.net
> >    mds@deb.platinumaire.net's password: 
> >    Permission denied, please try again.
> >    mds@deb.platinumaire.net's password: 
> >    Permission denied, please try again.
> >    mds@deb.platinumaire.net's password: 
> >    Permission denied (publickey,password,keyboard-interactive).
> > 
> > Fortunately, I have another logon that works.  I have logged on as
> > another user, su'd to mds, changed my password several times, tested it
> > while logged on -- each time, ssh logon fails:
> > 
> >    Oct 31 19:11:51 deb sshd[585]: Failed password for mds from 12.248.228.98 port 63393 ssh2
> >    Oct 31 19:12:04 deb last message repeated 2 times
> 
> OK, my bad, on the fetchmail/PAM thing, I forgot to change my fetchmail
> passwd -- so, fetchmail *CAN* remotely access my account on that remote
> box.
> 
> However, I still *CANNOT* ssh into my account on that box.

Furthermore, I have done this from the remote system:

   /usr/sbin/sshd -d -d -d -p 22222

Whereupon, when I attempt to ssh logon, I get this after the third
password entry:

   debug1: userauth-request for user mds service ssh-connection method password
   debug1: attempt 5 failures 5
   debug2: input_userauth_request: try method password
   debug3: mm_auth_password entering
   debug3: mm_request_send entering: type 10
   debug3: monitor_read: checking request 10
   debug3: mm_auth_password: waiting for MONITOR_ANS_AUTHPASSWORD
   debug3: mm_request_receive_expect entering: type 11
   debug3: mm_request_receive entering
   debug1: PAM password authentication failed for mds: Authentication failure
   debug3: mm_answer_authpassword: sending result 0
   debug3: mm_request_send entering: type 11
   Failed password for mds from 12.248.228.98 port 63816 ssh2
   debug3: mm_request_receive entering
   debug3: mm_auth_password: user not authenticated
   Failed password for mds from 12.248.228.98 port 63816 ssh2
   Connection closed by 12.248.228.98
   debug1: Calling cleanup 0x806e050(0x0)
   debug1: Calling cleanup 0x80629f0(0x0)

Other ssh logons are un-affected and function properly.

I suppose that I'll have to post to the openssh mailing list.

Any ideas?

-- 
Best Regards,

mds
mds resource
877.596.8237
-
Dare to fix things before they break . . .
-
Our capacity for understanding is inversely proportional to how much
we think we know.  The more I know, the more I know I don't know . . .
--

Attachment: pgpSQP7yrIp7c.pgp
Description: PGP signature


Reply to: