[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: via-rhine problems with dlink DFE-530TX [SOLVED, kinda]



On Thu, Oct 30, 2003 at 04:16:36PM -0500, ScruLoose wrote:
> Hi again, folks,
> 
> I have this kind of ongoing issue with a machine that's got a
> pretty-much clean install of woody, and has a D-Link DFE-530TX NIC in it
> that doesn't want to play nice with Debian.
> 
> When I configure it all up manually (specifying an IP and netmask on the
> ifconfig command-line and doing a route add for my default gw) and then
> ping my gateway, it lags for a while and then spits out this:
>   PING 192.168.1.1 (192.168.1.1): 56 data bytes
>   NETDEV WATCHDOG: eth0: transmit timed out
>   eth0: Transmit timed out, status 0000, PHY status 786d, resetting...
>   eth0: Reset not complete yet. Trying harder.
>   eth0: Setting full-duplex based on MII #1 link partner capability of 45e1.
>   
>   --- 192.168.1.1 ping statistics ---
>   17 packets transmitted, 0 packets received, 100% packet loss
<SNIP>
> At this point, I can only think of three things it might be:
>  -  Knoppix using some patches to the kernel or driver
>  -  My custom kernel has some option that conflicts with via-rhine
>  -  Knoppix is passing some arguments to the module
> 
> So now I'm trying to dismantle the process to see if I can figure out
> which it is.  Starting with arguments passed to the module, 'cause it
> seems easiest (and maybe most likely?)...
> 
> dmesg under knoppix (where the card works) shows this:
<SNIP>
> 
> Now, I'm noticing it says "VIA VT6105 Rhine-III at" different values...
> I dunno what that means but it kinda doesn't smell right.

Okay, it looks like I was barking up the wrong tree there.
Apparently, passing 'noapic' to the kernel at boot is the key, so I've
got it added to my lilo.conf...

But here's the peculiar thing: After booting with this 'noapic' option,
if I bring the card up with a valid IP and netmask _the first time_ (and
then add a route to the gateway) then everything's fine.  BUT, if I down
eth0 and bring it back up (even with the same arguments exactly) then
it's dead.  Same error as above. Nothing seems to revive it short of a
reboot.

Well, I seem to have it cobbled together well enough to get me by, but
I'll think twice before I buy a D-Link card again after this.

	Cheers!
-- 
,-------------------------------------------------------------------------.
>   -ScruLoose-   |         Do not meddle in the affairs of wizards       <
>  Please do not  |    for you are crunchy and taste good with ketchup.   <
> reply off-list. |                                                       <
`-------------------------------------------------------------------------'

Attachment: pgp0a5eV3rFj7.pgp
Description: PGP signature


Reply to: