[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ldconfig and hosing my system

Bill Benedetto <bbenedetto@goodyear.com> writes:

>  I ran "ldconfig" when I had an LD_LIBRARY_PATH variable set to
>  point to old old libraries.  Once "ldconfig" finished, then no
>  commands would work.  Nothing.

Oops.  :-(  If you happen to have a statically linked shell around,
then you could try adding 'init=/bin/sash' or something equivalent to
your kernel command line at boot time.  (In LILO, type 'linux
init=/bin/sash' or something equivalent; in GRUB, press 'e' at the
boot menu screen to edit what gets run.)

>  At this point I *BELIEVE* that I hosed /etc/ld.so.cache .  (I
>  could certainly be wrong, of course.)  But since I can't bring
>  the system up I don't know how to recreate /etc/ld.so.cache .

Right, that sounds consistent with what you're seeing.

>  I tried booting knoppix and using the /etc/ld.so.cache there but
>  the kernel still paniced upon reboot.  I don't know if the
>  kernel paniced the same way or not.

A kernel panic seems a bit weird, though maybe you're interpreting the
"can't load init" message as a kernel panic.  But if you can boot from
a Knoppix CD and mount your root partition (say, on /mnt), then either

  /mnt/sbin/ldconfig -r /mnt
  chroot /mnt /sbin/ldconfig

have a hope of working ("pretend that /mnt is the root directory, then
run ldconfig, which is statically linked").

David Maze         dmaze@debian.org      http://people.debian.org/~dmaze/
"Theoretical politics is interesting.  Politicking should be illegal."
	-- Abra Mitchell

Reply to: