[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

update-modules, sound on boot-up

I have a frustrating little problem with sound on boot-up.

Sound works if I manually load the required sound module:
$ su
# modprobe emu10k1
Result: Get great sound. :)

Then I try to make it permanent:
# update-modules

Then a re-boot to test...

Result: To my surprise on login there is this message:
Sound server informational message:  Error while initializing the sound
driver device /dev/dsp can't be opened (Permission denied)  The sound
server will continue, using the null output device

I don't think the device is the problem:
# ls -lat /dev/dsp
crw-rw-rw-    1 root     audio     14,   3 Mar 14  2002 /dev/dsp

I then decided to look in "/etc/modules.conf":
### update-modules: start processing /etc/modutils/sndconfig
alias sound-slot-0 emu10k1
post-install sound-slot-0 /bin/aumix -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix -f /etc/.aumixrc -S >/dev/null 2>&1 || :

### update-modules: end processing /etc/modutils/sndconfig

I don't understand what 'sndconfig' is up to.  I ran it when I was
installing the kernel (2.6.0-test6) and it didn't do anything for me; it
said that it couldn't find "soundcore.o" and suggested I was using an old
kernel ...yeah riiight!

So, 'sndconfig' seemed suspect... the little util that had once helped me
config sound seemed was now getting in the way... ergo:
# apt-get remove sndconfig

I then tried deleting the bit with 'sndconfig'... and did another
'update-modules' that didn't seem to change anything.  The above tid-bit
in "/etc/modules.conf" was regenerated which doesn't seem to be
progress... and something bothers me.

I then took a look at the boot log:
# dmesg
Serial: 8250/16550 driver $Revision: 1.90 $ IRQ sharing disabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
Creative EMU10K1 PCI Audio Driver, version 0.20a, 15:00:13 Oct 12 2003
emu10k1: EMU10K1 rev 7 model 0x8061 found, IO at 0xd400-0xd41f, IRQ 16
ac97_codec: AC97 Audio codec, id: 0x8384:0x7608 (SigmaTel STAC9708)
emu10k1: SBLive! 5.1 card detected
I don't see anything pointing to a problem there.  The computer seems to
know the sound card is there and even talks about the module
(emu10k1) needed to make it work.
I don't get it.

The only other thing I was looking at was "/etc/group"... 
I tried changing:
Where '1000' is the id of my normal user.

Any tips would be much appreciated.


PS - Yep... 'emu10k1' is the old sound arch.  I didn't have any luck with
ALSA (advanced linux sound arch).  The only thing I mananged to get it to
do is make my center speaker buzz... and that to me smelled like an issue
with the module; I had something like that once before.

Debian "Sid"
2.6.0-test6 kernel (with Debian patches)
KDE 3.1.3

Athlon XP 2200
512 MB RAM
NVIDIA GeForce 4
ASUS A7N8X Motherboard
SoundBlaster Live 5.1

Reply to: