[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dependency problems

On Tue, Oct 21, 2003 at 01:46:19PM +0200, Martin Wegmann said
> hello, 
> I have some dependency problems - broken packages and tried to fix them with 
> apt-get -f install/remove 
> but that does not work, any advice how to proceed? using testing/unstable
> Martin
> root@diomedea:/home/baliola# dpkg --configure -a
> dpkg: dependency problems prevent configuration of libqt3-mt-dev:
>  libqt3-mt-dev depends on libxcursor-dev; however:
>   Package libxcursor-dev is not installed.
> dpkg: error processing libqt3-mt-dev (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libarts1-dev:
>  libarts1-dev depends on libqt3-mt-dev; however:
>   Package libqt3-mt-dev is not configured yet.
> dpkg: error processing libarts1-dev (--configure):
>  dependency problems - leaving unconfigured
> Errors were encountered while processing:
>  libqt3-mt-dev
>  libarts1-dev
> root@diomedea:/home/baliola# apt-get -f install
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Correcting dependencies... Done
> The following extra packages will be installed:
>   libxcursor-dev
> The following NEW packages will be installed:
>   libxcursor-dev
> 0 upgraded, 1 newly installed, 0 to remove and 405 not upgraded.
> 2 not fully installed or removed.
> Need to get 0B/27.3kB of archives.
> After unpacking 135kB of additional disk space will be used.
> Do you want to continue? [Y/n] Y
> (Reading database ... 122861 files and directories currently installed.)
> Unpacking libxcursor-dev (from .../libxcursor-dev_1.0.2-2_i386.deb) ...
> dpkg: error processing /var/cache/apt/archives/libxcursor-dev_1.0.2-2_i386.deb 
> (--unpack):
>  trying to overwrite `/usr/X11R6/include/X11/Xcursor/Xcursor.h', which is also 
> in package xlibs-dev
> Errors were encountered while processing:
>  /var/cache/apt/archives/libxcursor-dev_1.0.2-2_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> root@diomedea:/home/baliola#

That's a bug in either libxcursor-dev or xlibs-dev.  Are they both up to
date with what's in sid?

Rob Weir <rweir@ertius.org> | mlspam@ertius.org  |  Do I look like I want a CC?
Words of the day: Kosovo Qaddafi USCOI Mafia ICE S Box covert video CISU Defcon

Attachment: signature.asc
Description: Digital signature

Reply to: