[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Couple of problems here... ;)

Using Woody 3.0r0 here...

First Problem USB Printing using CUPS

I have a HOWTO which tells me how to set up CUPS with a parallel port printer 
but I have a USB printer.  In the CUPS web setup I can add a printer but when 
I try to print the test page I get the following error:

Unable to open USB port device file "/dev/usb/lp0": No such device

How do I tell which port device to use?  Also can anyone point me to a HOWTO 
for setting up CUPS and a USB device  The error message pops up whenever I 
change the USB Printer #<Whatever>

/var/log/dmesg seems to indicate that the USB ports and the things that are 
connected to it are detected at boot.  I have a Microsoft Steering wheel as 
well as my printer.  I am using a stock bf24 kernel from the install disc.  

2nd Problem fonts...

Installed KDE 3.1.4 from their Debian repository at download.kde.org.  When I 
used the Font Installer to install new Truetype fonts from WinXP into 
/usr/X11R6/lib/X11/fonts/ttf.  The program ran all the necessary programs to 
generate the caches.

When I come to set up desktop fonts the fonts work fine as the root user but 
when I use a standard user the fonts all look like squares.  I'm not sure 
wether it is the fonts themselves which are not compatible for some reason or 
something else...

Extract from /var/log/messages
Oct 14 11:43:26 mats-pc-1 xfs: ignoring font path element 
/usr/X11R6/lib/X11/fonts/ttf/ (unreadable)

The problem is that the perms on the directory are the same as the perms on 
the other font directories:

mats-pc-1:/usr/X11R6/lib/X11/fonts# ls -al
total 108
drwxr-xr-x   10 root     root         4096 Oct 15 09:55 .
drwxr-xr-x    9 root     root         4096 Oct 15 09:10 ..
drwxr-xr-x    2 root     root        28672 Oct 15 09:55 100dpi
drwxr-xr-x    2 root     root        28672 Oct 15 09:55 75dpi
drwxr-xr-x    2 root     root         4096 Oct 15 09:55 Speedo
drwxr-xr-x    2 root     root         4096 Oct 15 09:55 Type1
drwxr-xr-x    3 root     root         4096 Oct 15 09:55 encodings
-rw-r--r--    1 root     root          138 Oct 15 09:55 fonts.cache-1
drwxr-xr-x    2 root     root         8192 Oct 15 09:55 misc
drwxr-xr-x    2 root     root        16384 Oct 15 13:07 ttf
drwxr-xr-x    2 root     root         4096 Oct 15 09:55 util

How would I go about fixing this one?? ;)

Sorry for the long first post!!

Reply to: