[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HELP!Problems with 160GB SATA drive

In article <FtR3.4XB.7@gated-at.bofh.it>, s-canagaratna@onu.edu says...
> I recently got a 700X  Gateway computer which comes with a 160 GB
> 6Y160M0 Maxtor hard drive. In the BIOS it is configured thus:
> ATA/IDE  Enhalnced (all SATA and PATA resources enabled
> Harddisk Pre-delay diabld
> LBA supported
> Block Mode 16
> PIO Mode Mode 4
> Ultra DMA 5
> Cable detected Serial
> The SATA is on port 0, and there is a dvd rom recognized as hdc and a
> zip drive recognized as hdd on PATA secondary (Master and Slave). It
> came with Windows XP and I partitioned it while XP was on into two
> a 20 GB for the XP; the rest I used XP to partition into two primary
> parts and an d extended partition.
> I tried to install debian Linux (unstable, from a CD rom created in
> March) but it hang up when it is asked to mount the cdrom. I tried
> tomsrtbt (version 2.03) but this also does not recognize /dev/hda (
> non-ide drive, CHS=1024/255/63). Maxtor's site gives the
> as
> ACTCYLS 317632, HDS:SECT 16:63, MAXCYLS 16,383
> I tried giving hd=16383,16,63 at boot time but it does not make any
> difference.
> I presumably will need a boot-disk having the latest kernel version.
> Any suggestions for doing this, or any other way of getting round the
> problem will be appreciated.

I don't know why Debian can't mount your CDROM.  Can you tell if it can
see the drive at all?  E.g. do you get the same messages or results if
there's no CD in the drive, or a different CD?

As for the SATA drive, I have two thoughts.  First, you don't say what
mobo or chipset your Gateway uses.  With my 865 chipset (Abit IS7 mobo),
in order for Linux to see my SATA drive at all I had to first rebuild my
kernel with the ATA | IDE block devices | Intel PIIXn chipsets support
option enabled.  Second, once SATA was enabled, my SATA drives would
show up as either hda and hdb, or hde and hdg, depending on the settings
in my BIOS.  So look around at some of the other devices and see if you
can find your SATA drive there.

Good luck,

Reply to: