[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Weird dependency problems installing mplayer...

I posted this once before, but figured it was worth another shot to see
if anyone could help, as I am still stuck...

I'm running testing. I was using mplayer and the mplayer-plugin for
mozilla just fine on my prior (athlon) system - I had mplayer-k7

I upgraded that system to a new mb and processor, so now it's a P4
system, and the installed mplayer was balking, so I removed the existing

Now, when I apt-get install mplayer-686, I get the following:
****output from apt-get follows
Reading Package Lists...
Building Dependency Tree...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  kde: Depends: kdebase-audiolibs but it is not going to be installed or
                kdebase3-audiolibs but it is not installable
  mplayer-686: Depends: libavcodec1 (>= 1:0.4.8) but it is not going to
be installed
               Depends: libvorbis0a (>= 1.0.0) but it is not going to be
*********end output

The only thing is, here's the output from:
 apt-show-versions | grep "audiolibs\|avcodec\|vorbis"
**********output follows:
libvorbisenc2/testing uptodate 1.0.0-3
libvorbis0 1.0.0-1 installed: No available version in archive
kdebase-audiolibs/testing uptodate 4:2.2.2-14
libvorbisfile3/testing uptodate 1.0.0-3
libavcodec0 1:0.4.6-sarge0.1 installed: No available version in archive
vorbis-tools/testing upgradeable from 1.0rc3-1 to 1.0.0-2
********end output

so it looks to be like audiolibs IS installed, while strangely it thinks
that libavcodec0 is installed
while having "no version in archive".

I should also note that "apt-get check" does not report any dependency

The whole problem seems to be the kdebase-audiolibs, because apt-get
install libavcodec1 fails because
libvorbis0a is not isntalled, AND apt-get install libvorbis0a fails
because kde has an
unmet dependence of kdebase-audiolibs....and I cannot apt-get remove
kdebase-audiolibs becuase it gives
the same unmet dependency for kde error as trying the install, while
apt-get install kdebase-audiolibs
tells me it is already installed. I tried apt-get --reinstall for both
kdebase-audiolibs and kde, but
that didn't fix the problem. I'm stuck.

Any suggestions would be mighty appreciated.


Reply to: