[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: A novice having trouble with X window on install

In linux.debian.user,
Charles Forelle <cforelle@comcast.net> wrote:
>  Michael,
>  Thanks. I ran xf86config as you suggested, selecting the generic video card
>  option since I didn't see mine (Intel chipset 82810E) in the list. (I
>  checked XF86Config file, and it just put vga in for the driver. I tried
>  startx 'which twm'
>  This is what I got back:
>  /usr/X11R6/lib/X11/xinit/xserverrc: /usr/bin/X11/X: No such file or
>  directory
>  /usr/X11R6/lib/X11/xinit/xserverrc: /usr/bin/X11/X: cannot execute: No such
>  file or directory
>  giving up.
>  xinit: No such file or directory (errno 2): unable to connect to X server
>  xinit: No such process (errno 3): Server error.
>  Now, I do have a /usr/bin/X11 directory, and there's lots of stuff in it,
>  but apparently not a file called 'X'
>  That seems like a problem, right? I didn't do anything fancy, just used the
>  Debian installer.

That is definately a problem.  Do you get anything with
which X

In the past X has always been a (sym)link to the appropriate server, in
my case running Deb 3.0r1, XFree86 Version, X is an elf binary,
not a link.  You could try

su -c "cd /usr/bin/X11 ; ln XFree86 X"

As long as its already broken expertimenting can't hurt.  Unfortunately
I'd fall back on reinstalling, there should be a way to force the
reinstall of just that package, I don't know for sure which package, and
it's probably moderately large.

Hopefully someone can give you details on which package and how to force

Good Luck,

Michael C.
mcsuper5@usol.com http://mcsuper5.freeshell.org/
Registered Linux User #303915 http://counter.li.org/

Reply to: